Am I on?

Asked by Allan on 2010-09-08

I have Transmission running on Lucid Linux and have been trying to get a torrent download.

The Transmission "page" reports Downloading from 0 of 0 connected peers - idle. Suggesting, I think, that all is well, except that none of my potential benefactors are currently on line.

However, going to Edit>Preferences>Network reveals port 51413 with "Status unknown" which, after "Test Port", changes to Port closed.

Can anyone tell me if I have a problem in addition to my impatience. And, if I do, how I may rectify it?

Thanks in advance.

Question information

English Edit question
Ubuntu transmission Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Ian Fleming (iflema-deactivatedaccount) said :


If you use a firewall, out going security basically needs to be open. Restricting to the standard port range(s) will only produce results from people offering the files on those ports = not everything available. The default incomming port 51413 if for a remote web interface to control torrents away from home. If you have no firewall active the torrent may be hosted by only a few and may take time if it finishes at all.

Revision history for this message
Allan (ad707) said :

Sorry but I don't know how to proceed.

I have read a lot of apparently conflicting information about ubuntu and firewalls and I do not know whether, as a simple result of installing 10.04, I now have a firewall or not. That said, I certainly did not install one nor "permit" ubuntu to do so.

So! I think I do not have one. But it is not clear to me whether or not that may be my problem.

Are you saying that, to get some sort of response from seeders I "should have" a firewall??

And port 51413 "IS" what I should have?

Just for some perspective, I am now 24 or more hours in and, as far as I can tell, nothing has been downloaded.

Revision history for this message
Ian Fleming (iflema-deactivatedaccount) said :


Ubuntu has a firewall installed by default but not active. Forget about port 51413 for now.
So... if the firewall was not configured and transmission has been running for that long, it sounds like a dude torrent.... have you tried other files/torrents? results?

Revision history for this message
Ian Fleming (iflema-deactivatedaccount) said :

in reference to the open ports..... the pre-configured range for torrents (in firewalls and some applications) is usually something as basic as port 6881 through to port 6889. But, with just this small range, that doenst cover much of the possibilities. Different torrent apps use different ranges of ports and people randomize and personalize their ports SO... really... ya want all out-going ports open when running torrents to cover all bases and get the file(s) as fast as is possible.

Fully blocked incomming (51413) has no affect on downloads.... only seeding (uploads) and remote administration.

Revision history for this message
Ian Fleming (iflema-deactivatedaccount) said :

if you where to only open port 51413 outgoing, for example.... you will only get hits from people using Transmission with default settings....

Revision history for this message
Allan (ad707) said :

O.k. I think you are saying that there is a chance that the "problem" is the torrent ... and that I should see what happens when I try another one.

I'll do that now ... and let you know.

Thanks for your help and insights.

Revision history for this message
Allan (ad707) said :

Well I guess this should have fallen under the heading "MUCH ADO ABOUT NOTHING".

I did as I said I would ... and a file started downloading virtually immediately (and, truth be known, is now pretty close to being finished).

So! All my concerns were for not. Evidently the only changes required are for more diligence in choosing torrents, a bit more patience ... and some faith.

Thanks for getting involved!

Revision history for this message
Allan (ad707) said :

That's all folks