Normal tray icon not displayed if indicator-applet not used

Asked by Sukochev Roman (Leolik) on 2010-05-04

Binary package hint: transmission

Ubuntu 10.04 LTS x86_64
Transmission 1.92 (10363)

I don't like indicator-applet and disable it. Then in settings.json add that changes:

...
"show-notification-area-icon": 0,
"show-tray-icon": 1,
...

but after this, when run Transmission - it not displayed in tray.
how back normal tray icon for transmission, which used in Ubuntu 9.10?

Sorry for my English.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu transmission Edit question
Assignee:
No assignee Edit question
Last query:
2010-05-04
Last reply:
2010-05-05
Chris Coulson (chrisccoulson) said : #1

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs#When%20not%20to%20file%20a%20bug.

Charles Kerr (charlesk) said : #2

Looking at the downstream appindicator patch, it doesn't seem to be possible with a copy of Transmission compiled with HAVE_LIBAPPINDICATOR defined -- the non-appindicator icon code is not compiled in the Ubuntu builds. Unfortunately it looks like you would need to roll your own copy.

Can you help with this problem?

Provide an answer of your own, or ask Sukochev Roman (Leolik) for more information if necessary.

To post a message you must log in.