port always closed in transmission

Asked by sahil dave on 2010-04-22

I installed this new OS 2 days earlier. cant download torrents cz the port is always closed. I am new to this so please tell me in detail.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu transmission Edit question
Assignee:
No assignee Edit question
Solved by:
Ian Ace
Solved:
2010-04-24
Last query:
2010-04-24
Last reply:
2010-04-23
Book 'em Dano (heymrdjd) said : #1

Are you connected to the internet via a router? If so, you need to enter the interface to the router (method to access router settings depends on the brand) to open the specific port for transmission to utilize. If your computer is directly connected to a DSL or cable modem you should seriously consider using a router, but in the mean time, you could use ufw (http://ubuntuforums.org/showthread.php?t=823741) or firestarter (https://help.ubuntu.com/community/Firestarter) to mointor your ports and open the ones you specify.

Once you have opened the port via the router or software, you would input that same number in the "Port for incoming connections field" of the Network tab in the Transmission preferences.

sahil dave (sahildave1991) said : #2

I dont get it...please explain it... i did 'sudo ufw enable' from the first link u gave of ufw... dont know how to use it....

now a letter on my keyoard is not working (which comes after A......A _ C D...),,,pls guess and make it work...

sahil dave (sahildave1991) said : #3

pls help...

Best Ian Ace (iaculallad) said : #4

If you're behind a router, you need to port-forward the port that you configured with Transmission. For more reading, here's a useful link:

http://www.portforward.com

HTH.

Book 'em Dano (heymrdjd) said : #5

Sahil Dave, are you just using a modem connected to a phone line or cable which is then connected to your computer via ethernet cable? What is the name of the modem or device that your computer uses to connect to the internet? These answers will determine which course of action to port forward/(open a port) for Transmission to use

sahil dave (sahildave1991) said : #6

I have modem. Beetel 110BX1a ethernet cable is connect to my computer.

Book 'em Dano (heymrdjd) said : #7

Use Firefox to login into web based interface of router/mode. Type url http://192.168.1.1/main.html or http://192.168.1.254/main.html. I don't know what the interface looks like, so I can't give exact instructions but you should search for the firewall options and refer to http://www.portforward.com/ for more info on how to port forward.

Perhaps if you tell us what options are available once you have gotten access to the router interface, we can provide more precise help.

Book 'em Dano (heymrdjd) said : #8

Use Firefox to login into web based interface of router/modem. Type url http://192.168.1.1/main.html or http://192.168.1.254/main.html. I don't know what the interface looks like, so I can't give exact instructions but you should search for the firewall options and refer to http://www.portforward.com/ for more info on how to port forward.

Perhaps if you tell us what options are available once you have gotten access to the router interface, we can provide more precise help.

sahil dave (sahildave1991) said : #9

on left side there is a panel with options
1. Device info
2. Advanced setup
3. Diagnostics
4. Managment

when i clicked diagnostics
there was FAIL written beside
           Test ATM OAM F5 segment ping: FAIL
           Test ATM OAM F5 end-to-end ping: FAIL
           Ping default gateway: FAIL

Book 'em Dano (heymrdjd) said : #10

Try Advanced Setup or Management options, look for some reference to a firewall and/or ports.

sahil dave (sahildave1991) said : #11

Thanks Ian Ace A. Culallad, that solved my question.