Transmission doesnt delete torrents

Asked by Heleen on 2010-02-24

I deleted two torrents in my transmission bittorrent client, but when I restart the programm [closing and then opening it again] the two torrents are back in the client. I also deleted the torrent together with the files, but this didn't help either.

I also rebooted my computer [I use Ubuntu Studio] and this didn't help... the two torrents won't go away.

does someone know how this happened? I find out that one of the two torrents was a virus, but I didn't open the file and deleted it directly after I found out. I don't know if this could be the cause. But does someone know what I can do so that these two torrents won't appear anymore? So that as usual the torrents will be deleted for ever...

I hope you can help me,

With kind regards,


Question information

English Edit question
Ubuntu transmission Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Tom (tom6) said : #1

Hi :)

Have you installed and tried "clamtk" as i find that a neat fast virus scanner. Also does Transmission have an "Edit" menu as in the "preferences" of that you should be able to change where Transmission looks for files to torrent.

Viruses rarely affect Linux of course but the concern here is if you are unwittingly helping infect Windows machines. Hopefully someone might be able to help you with that.

Good luck and regards from
Tom :)

Charles Kerr (charlesk) said : #2


What you're seeing is the same as the behavior described in <>, which is reportedly fixed in version 1.73. The cause for this behavior is detailed in that ticket, but a quick summary is that Transmission loads torrents on startup from $HOME/.config/transmission/torrents and also (to provide an upgrade path from older versions of Transmission) $HOME/.transmission/gtk/.

Three suggestions:

1. Upgrade to Transmission 1.73 or higher, if you haven't already. It's reported to fix this behavior. If that's not the case, please open a new ticket in launchpad's bug tracker.

2. A quick workaround would be to delete torrent files in question from those two folders manually.

3. You may also want to check the files in question, and those two folders, to make sure there's not a problem with their write permissions that prevents the files from being deleted.

Charles Kerr (charlesk) said : #3

Heleen: did this solve your problem?

Charles Kerr (charlesk) said : #4

Heleen: did this solve your problem?

Heleen (ubuntu-heleentje) said : #5

Hi Charles,

Thank you very much for your suggestions.

I already have transmission 1.75, so that is not the problem. I also deleted the files manually, but when I close transmission and restart it, all files will appear again... it's very very strange. I tried your options, but unfortunately it didn't work.

I'm thinking to uninstall Transmission and reinstall it again... maybe that might work.
If you have other suggestions, I'd like to hear them.

Again, thank you very much for your support. I really appreciate it.

Tom (tom6) said : #6

Hi :)

The style of answer of trying to "completely remove" Transmission, then delete files, reboot and check they are gone and then reinstall Transmission is a very Windows style but should work. I can't help thinking there is probably some clever, elegant linuxy way.

Good luck and regards from
Tom :)

Heleen (ubuntu-heleentje) said : #7


I had an update of Ubuntu, and since then the problem has been solved!! So I'm very happy that I didn't have to do a Windows kind of solution :) . So, I don't know what happened, but my problem is solved.

Guys, thanks a lot for all your help!!

Kinds regards from
Heleen :)

Tom (tom6) said : #8

Hi :)

Have you been able to test the new Ubuntu 10.04 before it gets officially released?
Trying it as a LiveCd or as an extra dual/multi-boot would be ideal. Developers and everyone are keen to try to iron out any problems before 10.04 gets officially released so you might find faster & more effective answers to your bug reports which would make 10.04 work better on your system for you

Thanks and regards from
Tom :)