trac 0.12 package?

Asked by Hendrik Fuß

Hi,

I would love to use the trac issue tracker in its latest version 0.12 on an ubuntu server. However, the current trac packages only use different flavours of 0.11. Are there plans to update the package to 0.12?

cheers
Hendrik

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu trac Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

sudo add-apt-repository ppa:cprov/ppa; sudo apt-get update; sudo apt-get upgrade

This only goes up to Lucid, this will not work for Maverick

Revision history for this message
Hendrik Fuß (hendrik-fuss) said :
#2

Excellent. I've tried the above commands, but I still do not see a more recent version of trac (dpkg shows 0.11.5-2ubuntu1.1).

My server still uses 9.10 (karmic). Do I need to upgrade to lucid?

Revision history for this message
Best actionparsnip (andrew-woodhead666) said :
#3

That PPA misses out karmic sadly. Bit weird. he has intrepid too which is EOL.

You could search for a deb or compile. You could contact Celso Providelo:
https://launchpad.net/~cprov/+archive/ppa

And see if he'll make the deb for you.

Revision history for this message
Hendrik Fuß (hendrik-fuss) said :
#4

Well, that's strange, because there is stuff under dists/lucid which looks alright to me. Anyway, I downloaded the following package:
http://ppa.launchpad.net/cprov/ppa/ubuntu/pool/main/t/trac/trac_0.12.1~ppa2_all.deb

I will have to make backups before upgrading, so I haven't tested it yet.
Thanks for your help!

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#5

Glad you got the gold :)