Ubuntu

totem-gstreamer colour problem (blue tint)

Asked by Zed on 2007-05-29

All video has a blue tint to it. All the codecs are updated.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu totem Edit question
Assignee:
No assignee Edit question
Solved by:
Cesare Tirabassi
Solved:
2007-05-29
Last query:
2007-05-29
Last reply:
2007-05-29
Cesare Tirabassi (norsetto) said : #1

Its just a particular video you are playing, any video or the whole monitor?

Zed (art-vaccarino) said : #2

All video...

Zed (art-vaccarino) said : #3

It is not a problem with the display hardware - only the videos in Totem have the blue tint

Cesare Tirabassi (norsetto) said : #4

Its the colour balance in Edit->Preferences->Display ok?

Zed (art-vaccarino) said : #5

yes, and if you move the sliders the tint/hue changes but it does not resolve the problem... Thanks for trying to help :) I am sure I have covered all of the basic possibilities including reinstalling totem and all codecs. I have a fully patched 7.04 system running on a ThinkPad R60 with ATI video.

Cesare Tirabassi (norsetto) said : #6

Are you using totem-xine or totem-gstreamer?
What are your ATI drivers, open source or proprietary?
And if proprietary, self compiled or from the restricted manager?
Can you also paste here your xorg.conf file?

Thanks.

Zed (art-vaccarino) said : #7

I am using the ATI Accelerated Graphics Driver restricted Driver - I believe they are open source installed from the restricted driver gizmo built into Ubunto
The totem is gstreamer and my xorg.conf follows

Thanks again...

------ cut here ------

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
        Fontpath "/usr/share/fonts/X11/misc"
        Fontpath "/usr/share/fonts/X11/cyrillic"
        Fontpath "/usr/share/fonts/X11/100dpi/:unscaled"
        Fontpath "/usr/share/fonts/X11/75dpi/:unscaled"
        Fontpath "/usr/share/fonts/X11/Type1"
        Fontpath "/usr/share/fonts/X11/100dpi"
        Fontpath "/usr/share/fonts/X11/75dpi"
        # path to defoma fonts
        Fontpath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
        Load "i2c"
        Load "bitmap"
        Load "ddc"
        Load "dri"
        Load "extmod"
        Load "freetype"
        Load "glx"
        Load "int10"
        Load "vbe"
EndSection

Section "InputDevice"
        Identifier "Generic Keyboard"
        Driver "kbd"
        Option "CoreKeyboard"
        Option "XkbRules" "xorg"
        Option "XkbModel" "pc105"
        Option "XkbLayout" "us"
EndSection

Section "InputDevice"
        Identifier "Configured Mouse"
        Driver "mouse"
        Option "CorePointer"
        Option "Device" "/dev/input/mice"
        Option "Protocol" "ImPS/2"
        Option "ZAxisMapping" "4 5"
        Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
        Identifier "Synaptics Touchpad"
        Driver "synaptics"
        Option "SendCoreEvents" "true"
        Option "Device" "/dev/psaux"
        Option "Protocol" "auto-dev"
        Option "HorizScrollDelta" "0"
        Option "SHMConfig" "on"
EndSection

Section "InputDevice"
        Driver "wacom"
        Identifier "stylus"
        Option "Device" "/dev/input/wacom"
        Option "Type" "stylus"
        Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
        Driver "wacom"
        Identifier "eraser"
        Option "Device" "/dev/input/wacom"
        Option "Type" "eraser"
        Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
        Driver "wacom"
        Identifier "cursor"
        Option "Device" "/dev/input/wacom"
        Option "Type" "cursor"
        Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
        Identifier "Generic Video Card"
        Driver "fglrx"
        Busid "PCI:1:0:0"
EndSection

Section "Monitor"
        Identifier "Generic Monitor"
        Option "DPMS"
EndSection

Section "Screen"
        Identifier "Default Screen"
        Device "Generic Video Card"
        Monitor "Generic Monitor"
        Defaultdepth 24
        SubSection "Display"
                Depth 1
                Modes "1400x1050" "(pitch" "1400)"
        EndSubSection
        SubSection "Display"
                Depth 4
                Modes "1400x1050" "(pitch" "1400)"
        EndSubSection
        SubSection "Display"
                Depth 8
                Modes "1400x1050" "(pitch" "1400)"
        EndSubSection
        SubSection "Display"
                Depth 15
                Modes "1400x1050" "(pitch" "1400)"
        EndSubSection
        SubSection "Display"
                Depth 16
                Modes "1400x1050" "(pitch" "1400)"
        EndSubSection
        SubSection "Display"
                Depth 24
                Modes "1400x1050" "(pitch" "1400)"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier "Default Layout"
  screen "Default Screen"
        Inputdevice "Generic Keyboard"
        Inputdevice "Configured Mouse"
        Inputdevice "stylus" "SendCoreEvents"
        Inputdevice "cursor" "SendCoreEvents"
        Inputdevice "eraser" "SendCoreEvents"
        Inputdevice "Synaptics Touchpad"
EndSection

Section "DRI"
        Mode 0666
EndSection
Section "Extensions"
        Option "Composite" "0"
EndSection

Cesare Tirabassi (norsetto) said : #8

Thanks,

lets try this:

launch gstreamer-properties from terminal
change the video output plugin to custom
change the video output pipeline to:

ffmpegcolorspace ! video/x-raw-yuv,format=(fourcc)YV12 ! xvimagesink

Test .....

Zed (art-vaccarino) said : #9

ZOMG! Its perfect! Thanks!

OK what did you do? Heh...

Best Cesare Tirabassi (norsetto) said : #10

Bug in the proprietary drivers that swaps the U and V planes.
The IY12 and I420 formats are identical except that the U and V planes are swapped, so we swap the swap :)
Can you mark this issue as solved, so that other users may find an immediate answer to their problems?

Thanks.

Zed (art-vaccarino) said : #11

Thanks Cesare Tirabassi, that solved my question.

theluddite (matt-aggus) said : #12

I've got the same problem, but I don't understand the solution posted by Cesare. I'm new to Linux. Where would I find "gstreamer-properties"? I found "gstreamer-properties.glade" in "/usr/share/gstreamer-properties/glade" but I'm not sure that's the right file. How do I launch it (from the terminal or otherwise)? When I take a look at the file with gedit, it's not at all apparent what I should be changing, which makes me think this isn't the right file at all. Can somebody help?

Just type in "gstreamer-properties" in the terminal and press enter. It will be obvious from there. Good luck!

holgi (holger-tasch) said : #14

Grazie, Cesare! This helped me, too.

Kyle (mmmkile) said : #15

I am so relieved. I could not figure it out. Thank you so much.

Kyle (mmmkile) said : #16

But when i test it, it says "Could not initialise Xv output"

brian (brian-corvil) said : #17

I had the same problem and tried the solution above, but hitting the test button produced an error:
 "Custom: could not link xvimagesink6 to ffmpegcsp13"

Do I need to install some other packages?

Joe Smith (yasumoto7) said : #18

Sweetness, this helped me out too. Thanks!

Jessica (sonicjmc-witchcast) said : #19

Setting it to X Window (No vX) works on my system! I think the ATi card just has a problem with autodetect. I had a system running Windows that failed to run correctly when certain things were set to autodetect.

Bubblegum (louitrilobite) said : #20

ffmpegcolorspace ! video/x-raw-yuv,format=(fourcc)YV12 ! xvimagesink

above works for me as does.. X Window (No vX) ..but then cpu usage goes up to 65% plus and it becomes unwatchably choppy.. and my whole system grindes to a halt..

Hey there, this is a problem for me too (except I get the same effect regardless of what media player I use). When I try to open the properties terminal gives me this message before the window opens:

gstreamer-properties-Message: Skipping unavailable plugin 'artsdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'pulsesink'
gstreamer-properties-Message: Skipping unavailable plugin 'sdlvideosink'
gstreamer-properties-Message: Skipping unavailable plugin 'v4lmjpegsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'qcamsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'esdmon'
gstreamer-properties-Message: Skipping unavailable plugin 'pulsesrc'

The, when I enter the pipeline you suggested I got this error message on the test:

Custom: could not link xvimagesink1 to ffmpegcsp1

Can anyone help me with this?

Here is my xorg.conf:

Section "Files"
EndSection

Section "InputDevice"
 Identifier "Generic Keyboard"
 Driver "kbd"
 Option "CoreKeyboard"
 Option "XkbRules" "xorg"
 Option "XkbModel" "pc105"
 Option "XkbLayout" "us"
EndSection

Section "InputDevice"
 Identifier "Configured Mouse"
 Driver "mouse"
 Option "CorePointer"
 Option "Device" "/dev/input/mice"
 Option "Protocol" "ImPS/2"
 Option "ZAxisMapping" "4 5"
 Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
 Identifier "Synaptics Touchpad"
 Driver "synaptics"
 Option "SendCoreEvents" "true"
 Option "Device" "/dev/psaux"
 Option "Protocol" "auto-dev"
 Option "HorizEdgeScroll" "0"
EndSection

Section "InputDevice"
 Driver "wacom"
 Identifier "stylus"
 Option "Device" "/dev/input/wacom"
 Option "Type" "stylus"
 Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
 Driver "wacom"
 Identifier "eraser"
 Option "Device" "/dev/input/wacom"
 Option "Type" "eraser"
 Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
 Driver "wacom"
 Identifier "cursor"
 Option "Device" "/dev/input/wacom"
 Option "Type" "cursor"
 Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
 Identifier "Generic Video Card"
 Driver "fglrx"
 Busid "PCI:1:0:0"
EndSection

Section "Monitor"
 Identifier "Generic Monitor"
 Option "DPMS"
 Horizsync 30-70
 Vertrefresh 50-160
EndSection

Section "Screen"
 Identifier "Default Screen"
 Device "Generic Video Card"
 Monitor "Generic Monitor"
 Defaultdepth 24
EndSection

Section "ServerLayout"
 Identifier "Default Layout"
  screen "Default Screen"
 Inputdevice "Generic Keyboard"
 Inputdevice "Configured Mouse"

 # Uncomment if you have a wacom tablet
 # InputDevice "stylus" "SendCoreEvents"
 # InputDevice "cursor" "SendCoreEvents"
 # InputDevice "eraser" "SendCoreEvents"
 Inputdevice "Synaptics Touchpad"
EndSection
Section "Module"
 Load "glx"
EndSection
Section "Extensions"
 Option "Composite" "0"
EndSection

Any help would be gratefully received...

Also had this problem setting it to Xwindows also solved it, I don't understand it just flipped one day?

Hi guys,

For some who the first fix didn't work, here is another custom line to try in the gstreamer-properties > Video > default output plugin > custom line:
videobalance hue=-1 ! autovideosink

Giovanni Figliozzi (giomini) said : #24

I had the same problem, and i found a solution. The problem (in my case) was this: if you restore the default settings about colours in totem preferences it will set the hue bar in the middle, like contrast, colour etc. Instead of this the hue bar should stay at the beginning (0) value, so the videos will play in the correct way. this bug influences also other programs, like vlc and xine (if I remember).
You can also set the hue with xvattr, but at the next opening of totem it will reset to the incorrect value.
I hope I can help, let me know

Shreepad S (shreepads) said : #25

Giovanni.. you're the man....

I got slightly better results by doing
- Hue to 0 as suggested
- Saturation bumped up 10%
- Contrast bumped down 10%
- Brightness bumped down 5%

As you've suggested this fixed VLC as well!!! I had uninstalled the default Totem Xine that comes with Xubuntu 7.10, installed VLC (which was working perfectly) and then installed Totem GStreamer (which screwed up VLC as well)

Thanks!

nori86 (neo-universe-1986) said : #26

Thanks a lot Giovanni! The way worked very well so far. Custom codes output the correct color during test but blue tint was left when I play DVD.

I'm having this problem, but I'm using Kubuntu and I don't have gstreamer-properties. Also, I use several different programs (Xine, Dragon) and need to know how to fix it on all.

Thanks heaps. Helped alot. I created a tutorial using the posts in this question. It is here: http://portablejim.site-hosts.net/Problems-and-Solutions/Hue-wrong-in-videos.html

Zed (art-vaccarino) said : #29

That is really helpful Portable-Jim. Thank you!

Zed: You're welcome.

glass.dimly (jmjohn) said : #31

I had this bug. I opened Totem (Movie Player) and changed
Edit->Preferences->Video.

I put the "Hue" slider all the way to the left. Don't ask me why but this fixed the problem.

-glass.dimly

rugburns499 (al-burns-email) said : #32

peitchie's fix worked for me, thanks peitchie

Markus Gut (mgut-run) said : #33

these fixes worked for me.

anyway, this bug appeared to me after upgrading from ubuntu jaunty jackalope 9.04 to karmic koala 9.10. what could have triggered the problem?

glass.dimly (jmjohn) said : #34

The fixes must be reversed, because Ubuntu Jaunty fixed the problem. So you have to reset your hue sliders to the middle, what they should have been at.

lcn_mustard (lcn-mustard) said : #35

Try: videobalance hue=-0 saturation=1 brightness=0.25 ! autovideosink

lcn_mustard (lcn-mustard) said : #36

Try: videobalance hue=-0 saturation=1 brightness=0.25 ! autovideosink

kunami (mastah-killa) said : #37

Despite not having an ATI card, this also happens to me after the upgrade to 9.10. I've tried both fixes, but with no luck, although this last one actually makes it a bit worse.

kunami (mastah-killa) said : #38

I forgot to mention that the video tab doesn't appear in Totem's preferences.

kunami (mastah-killa) said : #39

Solved it by changing the video output system to X Window System (no Xv). Are there any drawbacks to using this setting?

htaccess (linux-gamma) said : #40

I have had this issue with _every_ version of ubuntu I have used with this machine (4 or 5). Every time I upgrade it comes back. It effects nearly all my video players, vlc, xine, movie player and miro. Avidemux and mplayer seem to be ok. I assume its some underlying library/framework which is having some issue perhaps there's some bug with the propriety nvidia drivers im using, who knows, certainly not me.

Every time it happens i search google and find some random way to fix it, sometimes its a player based fix and sometimes its a fix for the underlying framework like gstreamer.

In the latest incantation of the issue (ie now on 9.10, NVIDIA Driver Version: 185.18.36,Server Vendor Version: 1.6.4 (10604000) ) I find myself here via google, i try the gstreamer-properties as suggested in this thread and get:

ffmpegcolorspace ! video/x-raw-yuv,format=(fourcc)YV12 ! xvimagesink
Custom: could not link xvimagesink4 to ffmpegcsp2

videobalance hue=-1 ! autovideosink
Custom: could not link autovideosink2 to ffmpegcsp

videobalance hue=-0 saturation=1 brightness=0.25 ! autovideosink
Custom: could not link autovideosink4 to ffmpegcsp5

so its still broken, http://portablejim.site-hosts.net/Problems-and-Solutions/Hue-wrong-in-videos.html is page not found, so back to google ...

Sorry. I changed my url system around.
New link (same article)
http://portablejim.site-hosts.net/tips/75-vlc-hue-wrong.html

Sorry. I changed my url system around.
New link (same article)
http://portablejim.site-hosts.net/tips/75-vlc-hue-wrong.html

gbinal (gbinal) said : #43

Thanks to everyone for helping on this. I was experiencing the same problem but for a much less impressive reason. For me, it was as simple as resetting the Hue in Movie Player->Edit->Preferences back to the middle. Not sure how it had ended up all the way to the left, but it seems that was the issue.

Osmo Laitinen (osmo-laitinen) said : #44

Great, I had this same problem on my other Ubuntu 10.10, not in notebook. Tested a few mentioned tricks and found out that previous one (gbinal's) fixed problem for me.

And I don't either have clue why hue wasn't on middle but on left.

Rémy (remy-garrigue) said : #45

Hello

I'm having the issue on Ubuntu 11.04, Inspiron 1720 with proprietary nvidia driver for GForce 8600M GT.

After reading this topic, the following command solved my issue:
xvattr -a XV_HUE -v 0
One other way to do this would have been to go through nvidia drivers gui
X Screen 0 / XServer XVideo Settings > Hue

I'ld like to ask a question to knowleadgeable people: I'm having an issue with my dual screen, an old Q17A which has decided one day to stay idle all the time., despite my best effort to re-configure it. It's detected by the driver, I can extend the desktop as usual, but the screen go idle asap when I press "power on" and never wake up.
It's still working fine with another laptop, so having the blue hue issue I wonder if that could be related ?

Thanks