how do i play a real media file

Asked by Tigre on 2007-05-22

I am new to linux. I know that i need wine to run an exe file. I am currently trying to run .rmvb files on totem, I do not know how to make it work

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu totem Edit question
Assignee:
No assignee Edit question
Last query:
2007-05-23
Last reply:
2008-02-28
SageMassa (jedd.bissegger) said : #1

try mplayer it has support for .rm files

sudo apt-get install mplayer mozilla-mplayer mplayer-fonts

Tigre (r-prakash-1986) said : #2

thanks but that did not solve my problem.There is an error message saying that it failed to initialize/open the video out device

Massimo Forti (slackwarelife) said : #3

error opening/initializing the selected video_out (-vo)device

Ok, this error is because you haven't select the right vo option. Open a mplayer, select configure (right click mouse --> Preferences) select Video section and after select xv or x11. Restart Mplayer. Thanks

Tigre (r-prakash-1986) said : #4

well now i have a new problem....the error says that it cannot find the codec matching -vo and video format 0x30345652
help!!1

SageMassa (jedd.bissegger) said : #5

Lets have you do the following

sudo aptitude install gstreamer0.10-pitfdll gstreamer0.10-ffmpeg gstreamer0.10-gl gstreamer0.10-plugins-base gstreamer0.10-plugins-good gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse libxine-extracodecs w32codecs

this is a large collection of media codecs.

Pookito pookito (pookito) said : #6

Hi, I am one of those guys trying to play rm files on ubuntu and I have not been successful by now. I am trying to play a rm file from the net and the mplayer plugin kicks in. A different window appear, it download the file but when it is about to play it stops. I have all the downloads but still it is not playing. Can you help me out here?

Thanks,

pookito

MobileDev (unrealnut) said : #7

I can help you guys solve your problem real quick! First of all, go to the MPlayer download page: http://www.mplayerhq.hu

Among other things, this packages allows MPlayer, Totem, and Kaffeine to play Windows Media 9 and most Real Media files, but the "latest and greatest" versions of either. Keep in mind that, depending on which country you live in, playing modern audio/video formats without Windows or Real Media Player installed, may be illegal. At any rate, don't go to their web site and grab their crappy Linux package. It's clunky and horrible, at least for me it was.

When you get to the site, you need to scroll all the way down and download the "essential codecs package". Be sure to get the ones for Linux, which are normally used for the Linux version of mplayer.
You could try the codecs package for Windows, but this is not guaranteed to work, especially if you don't have Wine installed

Create a directory called /usr/lib/win32/

You might need to be root in order to do this. If you don't want to do it from a shell, you can just open up the terminal, type "sudo thunar" (or whatever your file manager is) and do it all graphically.

Next, just unpack the whole gzipped tarball to any directory (within reason) and copy the contents of it over to /usr/lib/win32 (again, using said file manager as root). Just be sure to change the permissions on the directory, and all of it's contents, so that programs you start with non-root privileges can access the codecs. Yes, the codecs are DLLs, and you may need to have Wine installed in order for this to work. If your working with a duel-boot machine with Windows and Linux, you should have Wine installed anyway. It tends to save headaches, if you know how to use it.

Next, start up Totem and try playing those files again. It should automatically detect the new directory, and search for the appropriate codecs. If this doesn't work, then you could try using Kaffeine, which allows you to manually point it the directory where you keep the codecs. Also, Kaffeine's first-run setup wizard will tell you where to get newer versions of the Real Media codecs, so that you can enjoy your Real Media files without jumping from OS to OS. Keep in mind that Kaffeine is not for people with super old computers, those below 800 megahertz and/or 128 megabytes of memory. A big swap partition, between 150MB to 300MB may remedy this, but Kaffeine will start up slowly.

Dražen Lučanin (kermit666) said : #8

Thank you MobileDev!!!

I looked for a solution everywhere - installed gxine, mplayer, totem with all the codecs, but I couldn't make the damn rm file to work.

Finally, I installed Kaffeine and did what you explained with the codecs. Just a few tips for other people so they succeed quicker than I have - the codecs can be found under the download section, not directly on the above mentioned link; in Kaffeine go to settings, xine engine parameters, decoder and type /usr/lib/win32 under the external Real Media codecs path. Now I gotta go enjoy the video :D

Hi, it looks like this works for me:
sudo aptitude install gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-bad
After this I am able to play rm files using Totem (in Ubuntu 7.10)

David Freitas (jddcef) said : #10

Get RealPlayer for linux to play .rm files at

http://www.real.com/linux

generalenthu (galigutta) said : #11

I will not recommend the real player for Linux, in ubuntu 7.10. I have had this player crash multiple times and I dont like the interface at all.

Can you help with this problem?

Provide an answer of your own, or ask Tigre for more information if necessary.

To post a message you must log in.