Totem Player doesn plays DVDs

Asked by IDB Regiao Sul

Binary package hint: totem

The following error message appears:
Failed to connect stream: ok
It does not play DVDs

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/totem-gstreamer
Package: totem-gstreamer 2.24.3-0ubuntu1
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=pt_BR.UTF-8
 SHELL=/bin/bash
SourcePackage: totem
Uname: Linux 2.6.27-11-generic i686

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu totem Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:

This question was originally filed as bug #361887.

Revision history for this message
IDB Regiao Sul (idbregiaosul) said :
#1
Revision history for this message
Daniel Hollocher (chogydan) said :
#2

have you tried medibuntu?

Revision history for this message
Daniel Hollocher (chogydan) said :
#3

well, it looks like the codec is not installed.. You should try medibuntu.org

Revision history for this message
Pedro Villavicencio (pedro) said :
#4

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs.

Revision history for this message
Abi ^-^ (abiyasa-eka) said :
#5

Hello, you need to install some codec ...

Please enable your medibuntu repository first, and install the codec ...

Take a look at

https://help.ubuntu.com/community/RestrictedFormats/PlayingDVDs
https://help.ubuntu.com/community/Medibuntu

But i suggest you to try smplayer for playing DVD, it is great!

Good luck

Revision history for this message
gear3895 (gear3895) said :
#6

If VLC or Totem doesn't work, and you want to watch dvd movies or play downloaded flv video files and mp3 files in Ubuntu Linux,
Google for "flv flash Totem internal data stream vlc undf"
... it's better to install everything in 32 bit, even if you have a 64 bit machine, as there are something missing in 64 bit depository like drivers, codecs,...

Revision history for this message
marcobra (Marco Braida) (marcobra) said :
#7

Play mp3 and dvd under Ubuntu install skype googleearth acroread and other stuffs using Medibuntu

First please install https://help.ubuntu.com/community/RestrictedFormats

You need to have extra repositories enabled..

Please first enable the universe and multiverse repository:

Open System → Administration → Software sources → [ Tab Ubuntu software ]

enable "Community-maintained Open Source software ( universe )"
enable "Proprietary drivers for devices ( restricted )"
enable "Software restrictecd by copyright or legal issue ( multiverse )"

Close and confirm the repository reload.

Then open a Terminal from the menu Applications→Accessories→Terminal

Tip: right click with mouse on the terminal title caption and select the item "Always on Top" doing this you will force the terminal window to stay on top of the other windows and you will find very easy to copy single row from this web page into the terminal...
Something more about using the terminal https://help.ubuntu.com/community/UsingTheTerminal

Then type or better copy and paste a row a time then press enter:
(Tip: select the single row to copy then right click into the terminal and to quick paste click with middle button of mouse )

and type or better copy and paste:

sudo aptitude install vlc smplayer mplayer

To get better dvd playback and optional packages here the medibuntu available software list http://packages.medibuntu.org/
you need to add the medibuntu http://www.medibuntu.org/ repository to your /etc/apt/sources.list file:
( here the medibuntu howto https://help.ubuntu.com/community/Medibuntu but see below )

In short please open a Terminal from the menu Applications → Accessories → Terminal and type or copy and paste:

sudo wget http://www.medibuntu.org/sources.list.d/$(lsb_release -cs).list --output-document=/etc/apt/sources.list.d/medibuntu.list; sudo apt-get -q update; sudo apt-get --yes -q --allow-unauthenticated install medibuntu-keyring; sudo apt-get -q update

-- give your user password when requested, you don't see nothing when you type it, then press enter

Now to install, type:

sudo apt-get update
sudo apt-get install ubuntu-restricted-extras libxine1-ffmpeg non-free-codecs
sudo aptitude install libdvdread3 libdvdnav4 libdvdcss2 regionset gnome-mplayer
sudo aptitude install gstreamer0.10-pitfdll gstreamer0.10-plugins-good
sudo aptitude install gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse

Then to install the codecs if you are using:
-- a Ubuntu 32 bits:
sudo aptitude install w32codecs
-- a Ubuntu 32 bits:
sudo apt-get install w64codecs

give your user password when requested, you don't see nothing when you type it, then press enter.

Then to play encrypted dvd please read: http://www.ubuntugeek.com/playing-encrypted-dvds-in-ubuntu.html

You can also install other Medibuntu repository provided optional software http://packages.medibuntu.org/ :

sudo apt-get install skype
sudo apt-get install googleearth
sudo apt-get install acroread

Hope this helps

Can you help with this problem?

Provide an answer of your own, or ask IDB Regiao Sul for more information if necessary.

To post a message you must log in.