WMV files not playing

Asked by rex

I have a 64 bit amd system that will not play WMV files. Is there a converter for the WMV files? Is there a fix to play them also?Totem will not play anything on this system. XMMS will play mp3 on it so I know it is totem.

Question information

English Edit question
Ubuntu totem Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Bajtalan Hunor (cerebellum) said :


As far as I know, there is no difference in wmv files in 64 bit or 32 bit architecture. That is just hard thing. You can install a 32 bit operating system to 64 also just the fact is that does not use 64 bit.
So in case of ubuntu linux, or every other distro, playing wmv is not a free format so you can not play it, because you get for free ubuntu that is why does not include wmv, mp3, avi support.
Here you can find all the necessary tools to enable restricted formats https://wiki.ubuntu.com/RestrictedFormats

Revision history for this message
Lionel Dricot (ploum-deactivatedaccount) said :

Some WMV files can be well played with totem-gstreamer in Ubuntu Dapper. But nearly each WMV file is unique.

I suggest that you post a bug on http://gnome.bugzilla.org for each WMV file that is not well played with the latest GStreamer0.10.

For example, you can have a look at :

But indeed, some WMV files are in a restricted format that can't be played on Ubuntu AMD64 without some dirty hacks.

Revision history for this message
Hilton Gibson (hgibson) said :
Revision history for this message
rex (ahp-53) said :

codecs solved the issue. They have been updated and work fine.