Totem Video Driver Problems - Ubuntu Hardy Heron 8.04

Asked by Steve Alexander

Hi Guys!...
I posted this in Ubuntu forums but got no response... so far!
My computer is dual boot! Up until recently I was sharing my time between both about 50% but finally made the commitment to transfer all my files in Windows to Ubuntu! Before this time, Both Totem and MPlayer worked perfectly! Now I don't think that this was the cause as no settings were changed, just documents, pictures, and video files were imported. But I mention this as shortly after I went to play a video and noticed that it looked to have been corrupted or degraded. Now the Multimedia System Selector selection in Applications was set on "Auto Detect"! In MPlayer the video driver in use was "xv X11/xv".

Thinking it was the codecs I changed them but got the same result... Bad video! Essentially the video played at the correct speed, Audio was fine but the colours were screwed up with reds turning green etc. Not having any luck changing codecs I decided to concentrate on the Video Drivers! I changed MPlayer to "X11 (XImage/Shm) and discovered that it now worked perfectly both sound and video. On this assumption I returned to Multimedia System Selector and changed the setting to "X Window System (X11/XShm/xv)" but still had the same results!

On the theory that it must be "xv" causing the problem, I changed the setting there to "X Window System (No xv)" and regained all of the lost colour! The problem now is that while I have regained the colour, the video now resembles a jerky slide show with no proper video motion and blurred images. Sound is perfect, but the video shows in this fashion at half the speed it should! So far I have figured out on my own that "xv" is at fault, but don't know what to do to correct this problem. Were I to use MPlayer only I would not have any problems (It works fine!) but since the days when I first installed Ubuntu Edgy I have used Totem without a problem and still think it is cool!

How do I fix this problem? It has the potential to drive me nuts on my own! My video card is a "nVidia Geforce 4 Mx 440 AGP 8x" I am not that new to Ubuntu but lousy writing code or interacting in the terminal! My computer is up to date with all Gstreamers present including Xine! Can you help me please!!!!!


Question information

English Edit question
Ubuntu totem Edit question
No assignee Edit question
Solved by:
Gord Allott
Last query:
Last reply:
Revision history for this message
Best Gord Allott (gordallott) said :

i would make sure that you have your video drivers installed as this sounds like a hardware acceleration problem (xv uses your graphics card to accelerate the process of playing video). going to system -> administration -> hardware drivers should tell if you if you have any video card drivers you can install.

you also may wish to run 'glxinfo | grep direct' in a terminal, this will tell you if you have any 'direct rendering' which is needed for hardware acceleration. if that says yes you can run 'glxgears' in a terminal to test your hardware acceleration, a window should pop up with three gears spinning around, one large red one with a blue and green gear to the sides. if the colours in this are wrong or something goes wrong it may just be that your hardware is damaged or overheating.

Revision history for this message
Steve Alexander (steve-alexander) said :

Thank You Gord,

This seems to have been an oversight on my part! I recently changed hard drives (larger disc) and reinstalled Hardy Heron. On all the other times I installed the nVidia drivers and never had a problem! I want to thank you for helping me correct my oversight! Seems I have installed so much of late and transferred so many files from Windows that I just plain forgot about the drivers! After installing them I went back to the Multimedia Systems Selector and returned the setting to "X Window System (X11/XShm/xv)" then went to Totem to play a video. I admit I had to reset the colour balance in preferences to get it just right, but finally the reds are red, and the blues are blue, with the greens, green again! No jerky movement detected... In fact this is how it used to be in previous installs... Thank You Very Much!

Just sorry I had to submit a question to realise what I should have done first!