totem not playing movies

Asked by john on 2008-07-04

Binary package hint: totem

totem does not play movies when you put in dvd totem says erro can not read from resource please help

ProblemType: Bug
Architecture: i386
Date: Thu Jul 3 23:12:27 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/totem-gstreamer
NonfreeKernelModules: nvidia
Package: totem-gstreamer 2.22.1-0ubuntu2
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: totem
Uname: Linux 2.6.24-19-generic i686

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu totem Edit question
Assignee:
No assignee Edit question
Solved by:
john
Solved:
2008-07-07
Last query:
2008-07-07
Last reply:
2008-07-06

This question was originally filed as bug #245400.

john (johngraham) said : #1
Sebastien Bacher (seb128) said : #2

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at [WWW] https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see [WWW] https://help.ubuntu.com/community/ReportingBugs .

Hi John,

Totem plays DVD's but you need to install totem-xine.

Check this link for further details http://ubuntuforums.org/showthread.php?t=48812&highlight=totem&page=2. The issue has been resolved in this thread.

-Murali-

Bhavani Shankar (bhavi) said : #4

For multimedia issues, this page has useful information: https://help.ubuntu.com/community/RestrictedFormats - See also https://help.ubuntu.com/8.04/musicvideophotos/C/index.html - But please use free formats if you can: https://help.ubuntu.com/community/FreeFormats

in short:

You just have to install all the RestrictedFormats. You can simply type in a terminal:

sudo apt-get install ubuntu-restricted-extras

(if you have xubuntu or kubuntu, just replace the name in the instruction)

But prior to that you have to enable extra repos Please refer:

http://psychocats.net/ubuntu/sources

Regards

john (johngraham) said : #5

thanks for your ad vice but im totally lost at what to do i tried to installmedi um buntu
but i dont think it worked im not real good on computers but im trying my father in law istallled . um buntu on our computer and took off windows he said its a real safe system.but im dont think im computer literate enough to figure this out .ive got the printer working but thats about it.if somebody will call me to help i would be so thank full # is 928-227-3420 thank you john

Tang (robertmcgreg) said : #6

I've found there are people in the Ubuntu community with incredible patience. If you truly want to solve the problem, why not simply reply with the first part of the help offered that you don't understand yet?

CWii (cwii) said : #7

Posting you're phone number on the internet isn't a good idea :/

Tang is right. Respond to the above attempts to help, and they will help you more :)

john (johngraham) said : #8

ok i went into my soft ware source packages and under authenti cation it looks like i have medi umbuntu i tried to do sudo apt-get installumbuntu resrticted extras but i still dont have libdvdcss. did i do something wrong

CWii (cwii) said : #9

Could you copy and paste all of the output?

john (johngraham) said : #10

  On Sat, 2008-07-05 at 18:53 +0000, CWii wrote:
> Your question #38182 on totem in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/totem/+question/38182
>
> Status: Open => Needs information
>
> CWii requested for more information:
> Could you copy and paste all of the out what is the output

john (johngraham) said : #11

what is the output and where do i find it ? sorry it took so long to respond i had to work today

Tang (robertmcgreg) said : #12

Hope I don't interfere with other helpers, but I have just replicated and solved your problem for myself, and hope I can help you solve it too.

First. at the top panel on your screen, click [system]
In the box that then drops down, click [Administration]
in the next box click [Software Sources]
Click where it says [Third party software] and make sure both boxes there are ticked
At some stage you might get a little message to update. do so

Now, in the same administration section, directly under [software sources] click [Synaptic Package Manager]
click [Reload]
when your screen clears again, click [mark all upgrades]
If [Apply] changes color, click [Apply] and follow any instructions there

Next, click [Search] and type [totem-gstreamer] (but not the [] quotes)
click the little [search] that lights up underneath
now click with the right mouse button and select [mark for complete removal]
click apply
now click on [All] ( that's under reload)
now click on [Settings] at top of the Synaptic window
click [Preferences]
make sure the top four boxes are ticked
click [Apply]
click [OK]
Now click on [search] again and type in [ totem-xine ] and change [ look in ] to [ Name ]
click [ search ] then right click on totem-xine and select Mark for installation
click [ Apply ] at the top, click apply again, then when apply lights up again click it, click close
Close synaptic and watch a movie
 I hope!
Pleas let us know how you go before you get too wrapped up in the movie! :-)

john (johngraham) said : #13

ok ihave totem-xine totem totem plugins and totem mozilla itook off totem gstreamer but when i put in a movie i get erro occuerd movie encrypted are trying to play a movie without libdvdcss i have hardy 8.04 so do i need to do something else. thanks for your help

Tang (robertmcgreg) said : #14

Thanks for your reply
The only things I can suggest now is going back to synaptic and installing [ vlc ]
If vlc does work for you, go back to Synaptic again, and install [ mozilla-plugin-vlc ]
If that doesn't work, or you want to stick with totem, please say so, and someone with (hopefully) proper experience will replace me and help you get the most from Ubuntu

john (johngraham) said : #15

i tried vlc it did not work then itried to get libdvdcss in the terminaljohn@john-desktop:~$ sudo apt-get installlibdvdcss
[sudo] password for john:
E: Invalid operation installlibdvdcss
john@john-desktop:~$ sudo apt-get install libdvdcss
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libdvdcss is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package libdvdcss has no installation candidate
john@john-desktop:~$

this is what i got i hope i did this right

john (johngraham) said : #16

i wished i could show you my soft ware source but i havent figured out how to do this i know in my updates part i cant chec k or tick on important security updates for hardy all the others are checked on my third party i have 2 items one says hardy security multiverse resrticted the other says hardysecurity multi verse restrictedsource code in my umbuntu soft ware part i have all five boxes checked and my server is united states in my add and remove packages i have umbutu restricted packages checked but when i try to instal from terminal it says it cant find umbuntujohn@john-desktop:~$ sudo apt-get install umbuntu resticted packages
[sudo] password for john:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package umbuntu
john@john-desktop:~$

so what do i do now thank you every body for your help and patience with me

john (johngraham) said : #17

i got it to work i goggled totem not working in umbuntufound aweb site that icant remember but here is what they told me to do after you install medi umbuntu you go to terminal tpyesudo apt-get install build-essential debhelper fakeroot press evter after thats done then typesudo /usr/share/doc/libdvdread3/install-css.sh it worked forumbuntu8.04hardy thank you all for all of your help .

john (johngraham) said : #18

sorry mise spelledtype and enter was the other word thanks again john

Tang (robertmcgreg) said : #19

And you fixed it yourself!
Congratulations!

john (johngraham) said : #20

i could not have done this with out every bodys help thanks again

sonjalin (sonja-iki) said : #21

I though to write down my question to this thread cause it's quite similar.

I started to use Ubuntu a couple of weeks ago. Before I had Debian but my brother installed it. So I am not so experienced to work with a computer by my own.

I tried to watch a DVD with totem movie player and already installed totem-xine and ubuntu-restricted-extras. Anyway it says "could not read from resource" and doesn't show anything. Could someone help me?

I'm not so good at English but hope so you'll understand me. :)

john (johngraham) said : #22

hi sonjalin i had the same problem go to terminal and type sudoapt-get install build-essential deb helper fake root then pressenter key then type sudo/usr/share/doc/libdvd read3 install-css.sh hopefully it will work

john (johngraham) said : #23

hi sonjalin i had the same problem go to terminal and type sudoapt-get install build-essential deb helper fake root then pressenter key then type sudo/usr/share/doc/libdvd read3 install-css.sh hopefully it will work

sonjalin (sonja-iki) said : #24

Thanks! Now it works, or I hope so.