I cant import subtitles for non of the available mediaplayers (srt)

Asked by Tamas Nandori on 2006-11-20

I am beginner linux user. I followed the instructions of the home page, installed the recommended codecs for watching movies but the subtitles unfortunately don't work. The video file is avi, the subtitle is a an srt. I don't know whether it counts. None of the available media players does it (totem, VLC, gxine). Maybe I will try mplayer.

Regards,

Tamas Nandori

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu totem Edit question
Assignee:
No assignee Edit question
Last query:
2006-11-20
Last reply:
2006-11-23

Hi Tamas,

fwiw - I use mplayer for video playback but I'm familiar with vlc too. In VLC, I find that if the subtitle file has the same name as the movie, apart from the extension, it wil ldetect it automatically. For example if I open:

Herr.Lehmann.DVDRip.DivX.german.avi

VLC will automatically find

Herr.Lehmann.DVDRip.DivX.german.srt

You can also explicitly tell vlc which subtitle file to use when opening a file. Type ctrl-f for open, choose the movie you want to open and then check the box which reads "Use a subtitles file" and then browse for the subtitle file.

That's all I need to do but if that doesn't work, in the top menu, choose "video" and then "subtitles track" and make sure that "Track 1" is checked not "disable"

I hope that helps!

Tamas Nandori (tamas-nandori) said : #2

Hi Alex,

Thank you very much! It works. Unfortunately the transmission of
Hungarian vowels doesn't work like Hungarian file names. I hope this bug
can be fixed some time. But anyway I am very saisfied with this OS. I
will keep it on my computer.

Tamas

That's great and I'm glad you like Ubuntu!

I'm not entirely sure what problem you have with Hungarian vowels but you might want to do a bit of googling. If you think it's a bug, you might consider filing it at https://bugz.launchpad.net/

Alex

Sebastien Bacher (seb128) said : #4

Works according to the submitter, marking as solved. Feel free to open a bug for your encoding problem

Tamas Nandori (tamas-nandori) said : #5

Thank you again for everybody. I have already found the way how I can adjust the vlc player for Hungarian subtitles. At the movie opening window I could choose the encoding type. And as far as I can remember the third in the row, it was a long code, I can't remember exactly but it worked perfectly.
But I have still a similar problem. For CD-s which have been burned under Windows the hungarian vowels in file names are not recognized by the Ubuntu. The files can be opened, only their names can't be truly read. Maybe it also an encoding problem.

Tamas