Totem: An error occurred - Could not open location

Asked by Aisano on 2012-08-25

For a couple of days now I am unable to play audio CDs using totem. When I insert an audio CD into the drive Ubuntu asks me which application I would like to use to open it; when I choose totem I get a message box saying "An error occurred - Could not open location; you might not have permission to open the file" (in my language). Totem then shows a slash ("/") in the play list.

Until some time (not more than a couple of weeks) ago I had no problems with this, and I can play the disks perfectly using CD Player (goobox). I also can play MP3 and OGG files with totem.

I am running Ubuntu 12.04 with current updates (yesterday).

Thanks for any hints,
-- Aisano

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu totem Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-08-30
Last query:
2012-08-30
Last reply:
2012-08-27

Can you give the output of:

lsb_release -a; uname -a; apt-cache policy totem

Thanks

Aisano (info-ais-sanmarino) said : #2

I added some "LANG=en", and here's the output:

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise

Linux mycomputer 3.2.0-30-generic-pae #47-Ubuntu SMP Wed Aug 15 18:52:06 UTC 2012 i686 i686 i386 GNU/Linux

totem:
  Installed: 3.0.1-0ubuntu21.1
  Candidate: 3.0.1-0ubuntu21.1
  Version table:
 *** 3.0.1-0ubuntu21.1 0
        500 http://gd.tuwien.ac.at/opsys/linux/ubuntu/archive/ precise-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     3.0.1-0ubuntu21 0
        500 http://gd.tuwien.ac.at/opsys/linux/ubuntu/archive/ precise/main i386 Packages

If you use another media app, does it work ok?

Aisano (info-ais-sanmarino) said : #4

Ais I said above the same discs work perfectly with CD Player, and totem works perfectly with audio files. I just imported a CD track using asunder, which seems to prove that the CD drive works fine, and was able to play the imported file using CD Player or also Rhythmbox (which I normally do not use as it does not terminate when I close it); that seems to prove that the audio card works fine, too.

I just had the idea to try a video DVD, and I could play it using totem without problems. Only with audio CDs the error described above appears.

I opened gnome-mplayer (something I am not really familiar with), and under "open" it gave me the option to open an audio disc. This worked but branched me to a track-by-track view of the disc (Track1.wav, Track2.wav etc). I was not able to select the entire CD. As I have never used gnome-mplayer before I cannot say whether this is the normal behaviour.

Banshee plays audio CDs flawlessly.

Anything else I can try?

Thank you,
Aisano.

VLC has a play disk option just like mplayer, try that.....

Aisano (info-ais-sanmarino) said : #6

Thanks, I just installed VLC media player, and it plays my audio CDs just alright. Could be a replacement for totem. I just wonder what broke that capability in totem.
If nobody else reports my problem I will switch to VLC media player and declare my problem solved.

Aisano (info-ais-sanmarino) said : #7

Ok, looks like I am the only one with that problem, so I am switching to VLC media player, or maybe to goobox (seems to be better at finding media information than VLC). Thanks for the help.

Aisano (info-ais-sanmarino) said : #8

Thanks actionparsnip, that solved my question.