Codecs or decoders for totem player for wmv,avi files

Asked by laksan

Hello Everyone,
I am totally new to Linux and have been using Linux only in the last couple of days.I am not able to view movies which are basically in .avi,or .wmv format.I get a error message that the totem player is missing "codecs".From where can I download the codecs or decoders for the player?I am totally new and hence would like a detailed description.
Thanking you

Question information

English Edit question
Ubuntu totem Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
frozen (frozendude) said :

If you open totem, and click on "Edit" on the menubar, and then on "Preferences" you'll get an dialog with three tabs, make sure the tab called "General" is open and click "Add Proprietary Plugins...", this should open a file-manager window of a directory called "totem-addons", in this directory there should be symbolic links from files in the directory "/usr/lib/win32/".
To open this directory you can press [Ctrl]+[L] in any file-manager window and enter "/usr/lib/win32/", and just press [Enter].
If you find some odd files ending with ".ax", ".acm" or ".dll" and so forth, just mark all of them and drag them to the "totem-addons" window while holding [Ctrl] and [Shift].
If there are no files there you'll have to find them some other way, perhaps by downloading them from the internet.
The files you probably need are: "aslcodec_dshow.dll" "aslcodec_vfw.dll" "asusasv2.dll" "asusasvd.dll" "avimszh.dll" "avizlib.dll" "ctadp32.acm" "divxa32.acm" "" "divxc32.dll" "" "divx.dll" "huffyuv.dll" "" "iccvid.dll" "icmw_32.dll" "imaadp32.acm" "imc32.acm" "ir32_32.dll" "ir41_32.dll" "ir50_32.dll" "ivvideo.dll" "l3codeca.acm" "" "mpg4c32.dll" "" "msadp32.acm" "msg711.acm" "msgsm32.acm" "msh261.drv" "msrle32.dll" "msvidc32.dll" "" "ubvmp4d.dll" "ultimo.dll" "VDODEC32.dll" "vdowave.drv" "wma9dmod.dll" "wmadmod.dll" "wmsdmod.dll" "wmspdmod.dll" "" "wmv9dmod.dll" "wmvadvd.dll" "wmvdmod.dll" "" "wnvplay1.dll" "wnvwinx.dll" "vp31vfw.dll" "vp5vfw.dll" "vp6vfw.dll" "vid_3ivX.xa" "vid_cvid.xa" "vid_cyuv.xa" "vid_h261.xa" "vid_h263.xa" "vid_iv32.xa" "vid_iv41.xa" "vid_iv50.xa" and maybe some more.
After this you should have the codecs needed.

If you are unclear about any of this, please drop a comment.

Revision history for this message
laksan (sandeepraml) said :

Thanks for the Reply.I dont see any options like"Add Proprietary Plugins"under General tab.Am I using a older version of Totem Player.I am using version 1.2.0.I havent tried the second part of the solution yet.Thanks in advance

Revision history for this message
frozen (frozendude) said :

Well, the folder the "Add Proprietary Plugins..." button is supposed to open is in ".gnome2/totem-addons/" under your home-directory. I'll check if that works with the 1.2 release.

Revision history for this message
Bryan (stinkyewalk) said :

I have Version 5.10 and i also have no "Add Proprietary Plugins..." option. I would like to add these plugins aswell. also I cant seem to be able to install anything at all. I just installed this OS I think I need lots of help to run it well.t

Revision history for this message
mfuegem (midofe) said :

do you have already installed:
apt-get install totem-xine

Revision history for this message
slibuntu (stuohy1) said :

i went to install the totem-xine, and it tried to uninstall ubuntu-desktop, this doesnt sound good to me, is it normal?

Revision history for this message
synergz (synergz) said :

I had the default version of ubunto toem added, and could not find the codec add page as described above

I did the following

sudo apt-get install totem-xine
the bersion I have now is totem 1.4.3
and xine 1.1.1

the general tab under edit preferences has 3 sections
TV out
and subtitles

Add Prorietry plugins is not an available option ( not even greyed out)

Also I have no directory /usr/lib/win32, or anything similar

I then did a search in synaptics for win32, and found 2 avi file plugins, and Mplayer, I loaded these, but I still cannot play about 60% of the WMV files I find ( no change from before), in general vlc works better than totem or kaffiene.

I hope somebody can help me resolve this issue

Revision history for this message
blade (adriangrant06) said :

u need to creat the folder win32, as root do mkdir win32, mplayer has the codes extract after downloading them and place them in /usr/lib/win32/ make sure the perm is set to r-x for eveyone else, u can do this by typing chmod 755 /usr/lib/win32/, chmod 755 /usr/lib/win32/*.

Revision history for this message
blade (adriangrant06) said :

o yea the Add Proprietary Plugins is in the settings option, might be labeled xine settings for totem but thats only for Real codecs, u have to tell it where the codecs is saved, for Mandriva 2006 it has to be in /usr/lib/RealPlayer9/Codecs/ (note the CaPs) for mplayer to play .rm real media. just do what i said 4 the win32 and everything will be ok, i had the same problem yesterday but by night i figured it out. i hope this is helpful to someone

Revision history for this message
Ricci (riccisayer) said :

All I can say is that I have loaded Divx, Libdvd, win34/64 and still have half a dozen avis that nothing, including VLC, will play. I have been working on this for over 2 weeks, on and off, I have followed all links in all Ububntu pages I could find, relating to this, tried everything related on all the forums, some helpful, most not, or not relevant to Gutsy. I'm fed up, worn out and have reached such depths of depression over this that I'm going to watch Gone With the Wind, it plays!!!
 Any suggestions that will keep me out of the funny farm gratefully received

Can you help with this problem?

Provide an answer of your own, or ask laksan for more information if necessary.

To post a message you must log in.