Video players exit before play starts

Asked by Ingolemo on 2006-09-07

Whenever I try to open a video file in Totem, it opens up for a few seconds, resizes the window to the size of the video, and then exits without any error message.

I was able to play the same file without a hitch when I first installed Ubuntu a couple of weeks ago, so I have a feeling I've managed to break it through my tinkering.

A similar thing happens when I try to do the same thing in VLC and MPlayer.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu totem Edit question
Assignee:
No assignee Edit question
Solved by:
Dean Sas
Solved:
2008-01-22
Last query:
2008-01-22
Last reply:
2006-09-19
Dean Sas (dsas) said : #1

Do you get any output on the terminal if you run totem from that. You can access the terminal by going to applications -> accessories -> terminal

Ingolemo (ingolemo) said : #2

This is what I got after opening one of my MPEG files:
The program 'totem' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 73 error_code 11 request_code 140 minor_code 19)

Best Dean Sas (dsas) said : #3

Hi, this is probably related to one of the two bugs I've linked. Do you know what video resolution the video is at and the size of the video memory?

Ingolemo (ingolemo) said : #4

I looked at the other bugs and they do seem to decribe my situation. I found that the fix of changing the video output to "no xv" made most videos work.

I have an nVidia GeForce4 MX 440 though I'm currently using the nv driver (can seem to get the proper one working).

Ingolemo (ingolemo) said : #5

*can't

Lee McKusick (leemck) said : #6

When trying to run mplayer from the command line, In LTS 6.10 Ubuntu upgraded from the ubgrade window: Just playing generic camera mpg video files on hard disk. Worked in Breezy:

"mplayer filename.mpg" - draws window and exits.

Error message (selected part):

"X11 error: BadAlloc (insufficient resources for operation)?,?% 2 0

MPlayer interrupted by signal 6 in module: vo_check_events
- MPlayer crashed. This shouldn't happen."

Ingolemo (ingolemo) said : #7

Thanks Dean Sas, that solved my question.