Totem produces sound but not picture ("xvid not found").

Asked by Sebastian on 2010-08-27

Binary package hint: totem

Movie not able to be seen only sound can be heard. try to load xvid codec not able to load..........what can be done. Just load UBUNTU new to linux

sebastian

ProblemType: Bug
Architecture: i386
Date: Fri Aug 27 18:13:41 2010
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/totem-gstreamer
Package: totem-gstreamer 2.22.1-0ubuntu2
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: totem
Uname: Linux 2.6.24-16-generic i686

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu totem Edit question
Assignee:
No assignee Edit question
Last query:
2010-08-27
Last reply:
2011-02-27
Sebastian (sebsonik) said : #1
Pedro Villavicencio (pedro) said : #2

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs#When%20not%20to%20file%20a%20bug.

Play mp3 and dvd and other stuffs under Ubuntu using Medibuntu

First please install https://help.ubuntu.com/community/RestrictedFormats

You need to have extra repositories enabled..

Please first enable the universe and multiverse repository:

Open System → Administration → Software sources → [ Tab Ubuntu software ]

enable "Community-maintained Open Source software ( universe )"
enable "Proprietary drivers for devices ( restricted )"
enable "Software restrictecd by copyright or legal issue ( multiverse )"

Close and confirm the repository reload.

Then open a Terminal from the menu Applications→Accessories→Terminal

Tip: right click with mouse on the terminal title caption and select the item "Always on Top" doing this you will force the terminal window to stay on top of the other windows and you will find very easy to copy single row from this web page into the terminal...
Something more about using the terminal https://help.ubuntu.com/community/UsingTheTerminal

Then type or better copy and paste a row a time then press enter:
(Tip: select the single row to copy then right click into the terminal and to quick paste click with middle button of mouse )

and type or better copy and paste:

sudo aptitude install vlc smplayer mplayer

To get better dvd playback and optional packages here the medibuntu available software list http://packages.medibuntu.org/
you need to add the medibuntu http://www.medibuntu.org/ repository to your /etc/apt/sources.list file:
( here the medibuntu howto https://help.ubuntu.com/community/Medibuntu but see below )

In short please open a Terminal from the menu Applications → Accessories → Terminal and type or copy and paste:

sudo wget http://www.medibuntu.org/sources.list.d/`lsb_release -cs`.list --output-document=/etc/apt/sources.list.d/medibuntu.list; sudo apt-get -q update; sudo apt-get --yes -q --allow-unauthenticated install medibuntu-keyring; sudo apt-get -q update

-- give your user password when requested, you don't see nothing when you type it, then press enter

Now to install, type:

sudo apt-get update
sudo apt-get install ubuntu-restricted-extras libxine1-ffmpeg
sudo aptitude install libdvdread3 libdvdnav4 libdvdcss2 regionset gnome-mplayer
sudo aptitude install non-free-codecs w32codecs
sudo aptitude install gstreamer0.10-pitfdll gstreamer0.10-plugins-good
sudo aptitude install gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse
sudo /usr/share/doc/libdvdread4/install-css.sh

give your user password when requested, you don't see nothing when you type it, then press enter.

You can also install other Medibuntu repository provided optional software http://packages.medibuntu.org/ :

Also optionally you can also install googleearth ans skype:
sudo apt-get install googleearth
sudo apt-get install acroread

Hope this helps

I have the same problem as described above("Movie not able to be seen only sound can be heard").I have downloaded medibuntu and restricted packages etc, and have "fixed" the same problem in VLC, by changing the video output to "X11 video output (XCB)", but cannot find anywhere in the totemplayer settings to change the output... Can anybody help, please?

Can you help with this problem?

Provide an answer of your own, or ask Sebastian for more information if necessary.

To post a message you must log in.