No DVD replay. ´no URI for DVD implemented´

Asked by Kevin Michael Hedley

I´ been fiddling around for days with all the tips about downloading the Medibuntu Repository, installing libdvdcss2 etc and all seem to be in my computer now. Despite this, the machine still refuses to play commercial DVDs and continues togive the same fault message. I had everything up and running perfectly up until a couple of weeks ago when I needed to reinstall Ubuntu after a crash. Please, I am not a computer expert!

Question information

English (United Kingdom) Edit question
Ubuntu totem Edit question
No assignee Edit question
Solved by:
Jean Roberto Souza
Last query:
Last reply:
Revision history for this message
Best Jean Roberto Souza (sjeanr) said :

Have you tried VLC media player?

On terminal type:

sudo apt-get install vlc

VLC is the VideoLAN project's media player. It plays MPEG, MPEG2, MPEG4,
DivX, MOV, WMV, QuickTime, mp3, Ogg/Vorbis files, DVDs, VCDs, and multimedia
streams from various network sources.

Like Adobe Flash and proprietary media formats, playback of encrypted DVDs is something that Ubuntu can’t distribute in the default desktop. Adding support for playing your commercial DVD videos in Ubuntu isn’t a difficult task.

Whenever you insert a DVD, the Totem Movie Player should launch and begin playing the disk. Unfortunately, Totem makes a really poor DVD player as it does not support DVD menus. It’s possible to install a different back-end for Totem to play DVD menus, but I just like to use the VLC media player instead. I’ve found that VLC does a fantastic job with DVDs.

Revision history for this message
Jean Roberto Souza (sjeanr) said :

You can also find VLC on Ubuntu Software Center or Synaptic!

Clic Applications

Add Software



Ubuntu Software Center




Synaptic Package Manager

If that does not help you or sounds too complicated come back and shout your frustration, I will try my best to find a solution. :D I hope you are able to see your DVD by now!
Good luck!

Revision history for this message
Kevin Michael Hedley (khedley2001) said :

Wonderful! Solved in a couple of seconds by downloading VLC via the software centre. Many thanks, Kevin Hedley