Problem compiling libtotem-pl-parser on a mavrick machine

Asked by Rob Schmidt on 2010-12-01

I've run the build a couple of times and get to this:

dh_install: libtotem-plparser-dev missing files (debian/tmp/usr/share/gir-*), aborting
make: *** [binary-install/libtotem-plparser-dev] Error 255
dpkg-buildpackage: error: debian/rules binary gave error exit status 2
Build command 'cd totem-pl-parser-2.32.1 && dpkg-buildpackage -b -uc' failed.
E: Child process failed

I'm trying to backport so that might be the problem?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu totem-pl-parser Edit question
Assignee:
No assignee Edit question
Solved by:
mycae
Solved:
2010-12-02
Last query:
2010-12-02
Last reply:
2010-12-02
mycae (mycae) said : #1

dh_install is checking the listed files it has generated from the install target in debian/rules .

 If they are using the CDBS makefiles, then you can probably modify "debian/cdbs-package-list" to drop this file and ignore the error. Why it is not being installed is not clear -- bypassing the error may be treating the symptoms, not the actual problem.

Can you give the version you are trying to rebuild, and your ubuntu version?

Rob Schmidt (rjeschmi) said : #2

ah I think I found the problem.

The version of libgirepository and gobject-introspection need to be newer:

from debian/control:

      Build-Depends:
               ....
               libgirepository1.0-dev (>= 0.6.14),
               gobject-introspection (>= 0.6.14),
               ....

The versions from maverick don't work. (Version: 0.9.3-0ubuntu4)

The version from natty does (Version: 0.9.12+git20101124-0ubuntu1)

Best mycae (mycae) said : #3

Well, good that you solved your problem! but its a bit odd. dpkg-buildpackage should be checking your package database to ensure that you have the requisite versions specified in build-depends. It is possible that the original author has not put a strict enough build-dep in, and that *might* explain it.

Without trying to replicate your setup (too much time :) ) it is hard to say.

Rob Schmidt (rjeschmi) said : #4

Thanks mycae, that solved my question.