tomboy failed to sync to ubuntu one

Asked by Josh Rummel on 2010-09-10

Tomboy was able to sync for me once, but not again. I removed the machine from my one profile, removed all of my notes from tomboy, removed and reinstalled tomboy from the software center, set up the sync again, and still have no luck.

The sync window tells me that it failed, but if I expand the window it shows that all notes are synced. However, on the one dashboard, it says I've only got 3 notes (instead of 60), but none of them show up when I click the "notes" link.

I ran tomboy from the terminal with the --debug option, but I don't really know what to make of the output. It looks like a server error, but that's happening every time I've tried it over the last couple of weeks.

I'd really like to get tomboy to sync to one. Any help?

josh@josh-laptop:~$ tomboy --debug
** Running Mono with --debug **
[DEBUG 21:20:52.825] NoteManager created with note path "/home/josh/.local/share/tomboy".
[DEBUG 21:20:52.933] EnableDisable Called: enabling... True
[DEBUG 21:20:52.937] Binding key '<Alt>F12' for '/apps/tomboy/global_keybindings/show_note_menu'
[DEBUG 21:20:52.940] Binding key '<Alt>F11' for '/apps/tomboy/global_keybindings/open_start_here'
[INFO 21:20:53.388] Initializing Mono.Addins
[DEBUG 21:20:53.492] AddinManager.OnAddinLoaded: Tomboy.Tomboy
[DEBUG 21:20:53.500] Name: Tomboy.Tomboy,0.10
[DEBUG 21:20:53.500] Description:
[DEBUG 21:20:53.500] Namespace: Tomboy
[DEBUG 21:20:53.500] Enabled: True
[DEBUG 21:20:53.500] File: /usr/lib/tomboy/Tomboy.exe
[DEBUG 21:20:54.411] AddinManager.OnAddinLoaded: Tomboy.WebSyncServiceAddin
[DEBUG 21:20:54.411] Name: Web Sync Service Add-in
[DEBUG 21:20:54.411] Description: Synchronize Tomboy Notes with Tomboy Online and other compatible web services
[DEBUG 21:20:54.411] Namespace: Tomboy
[DEBUG 21:20:54.411] Enabled: True
[DEBUG 21:20:54.411] File: /usr/lib/tomboy/addins/WebSyncServiceAddin.dll
[DEBUG 21:20:54.413] AddinManager.OnAddinLoaded: Tomboy.SshSyncServiceAddin
[DEBUG 21:20:54.413] Name: SSH Sync Service Add-in
[DEBUG 21:20:54.413] Description: Synchronize Tomboy Notes to a SSH share
[DEBUG 21:20:54.413] Namespace: Tomboy
[DEBUG 21:20:54.414] Enabled: True
[DEBUG 21:20:54.414] File: /usr/lib/tomboy/addins/SshSyncServiceAddin.dll
[DEBUG 21:20:54.419] Unable to locate 'gnomesu' in your PATH
[DEBUG 21:20:54.420] Using '/usr/bin/gksu' as GUI 'su' tool
[DEBUG 21:20:54.420] Successfully found all system tools
[DEBUG 21:20:54.420] Unable to locate 'sshfs' in your PATH
[DEBUG 21:20:54.421] AddinManager.OnAddinLoaded: Tomboy.WebDavSyncServiceAddin
[DEBUG 21:20:54.421] Name: WebDav Sync Service Add-in
[DEBUG 21:20:54.421] Description: Synchronize Tomboy Notes to a WebDav URL
[DEBUG 21:20:54.421] Namespace: Tomboy
[DEBUG 21:20:54.421] Enabled: True
[DEBUG 21:20:54.421] File: /usr/lib/tomboy/addins/WebDavSyncService.dll
[DEBUG 21:20:54.422] Unable to locate 'wdfs' in your PATH
[DEBUG 21:20:54.423] AddinManager.OnAddinLoaded: Tomboy.FileSystemSyncServiceAddin
[DEBUG 21:20:54.423] Name: Local Directory Sync Service Add-in
[DEBUG 21:20:54.423] Description: Synchronize Tomboy Notes to a local file system path
[DEBUG 21:20:54.424] Namespace: Tomboy
[DEBUG 21:20:54.424] Enabled: True
[DEBUG 21:20:54.424] File: /usr/lib/tomboy/addins/FileSystemSyncService.dll
[DEBUG 21:20:54.803] AddinManager.OnAddinLoaded: Tomboy.ExportToHtmlAddin
[DEBUG 21:20:54.803] Name: Export to HTML
[DEBUG 21:20:54.803] Description: Exports individual notes to HTML.
[DEBUG 21:20:54.803] Namespace: Tomboy
[DEBUG 21:20:54.803] Enabled: True
[DEBUG 21:20:54.803] File: /usr/lib/tomboy/addins/ExportToHtml.dll
[DEBUG 21:20:54.804] AddinManager.OnAddinLoaded: Tomboy.PrintNotesAddin
[DEBUG 21:20:54.805] Name: Printing Support
[DEBUG 21:20:54.805] Description: Allows you to print a note.
[DEBUG 21:20:54.805] Namespace: Tomboy
[DEBUG 21:20:54.805] Enabled: True
[DEBUG 21:20:54.805] File: /usr/lib/tomboy/addins/PrintNotes.dll
[DEBUG 21:20:54.806] AddinManager.OnAddinLoaded: Tomboy.BacklinksAddin
[DEBUG 21:20:54.807] Name: Backlinks
[DEBUG 21:20:54.807] Description: See which notes link to the one you're currently viewing.
[DEBUG 21:20:54.807] Namespace: Tomboy
[DEBUG 21:20:54.807] Enabled: True
[DEBUG 21:20:54.807] File: /usr/lib/tomboy/addins/Backlinks.dll
[DEBUG 21:20:54.808] AddinManager.OnAddinLoaded: Tomboy.EvolutionAddin
[DEBUG 21:20:54.809] Name: Evolution Mail Integration
[DEBUG 21:20:54.809] Description: Allows you to drag an email from Evolution into a Tomboy note. The message subject is added as a link in the note with an envelope icon next to it.
[DEBUG 21:20:54.809] Namespace: Tomboy
[DEBUG 21:20:54.809] Enabled: True
[DEBUG 21:20:54.809] File: /usr/lib/tomboy/addins/Evolution.dll
[DEBUG 21:20:54.813] AddinManager.OnAddinLoaded: Tomboy.FixedWidthAddin
[DEBUG 21:20:54.813] Name: Fixed Width
[DEBUG 21:20:54.813] Description: Adds fixed-width font style.
[DEBUG 21:20:54.813] Namespace: Tomboy
[DEBUG 21:20:54.813] Enabled: True
[DEBUG 21:20:54.813] File: /usr/lib/tomboy/addins/FixedWidth.dll
[DEBUG 21:20:54.815] AddinManager.OnAddinLoaded: Tomboy.StickyNoteImportAddin
[DEBUG 21:20:54.816] Name: Sticky Notes Importer
[DEBUG 21:20:54.816] Description: Import your notes from the Sticky Notes applet.
[DEBUG 21:20:54.816] Namespace: Tomboy
[DEBUG 21:20:54.816] Enabled: True
[DEBUG 21:20:54.816] File: /usr/lib/tomboy/addins/StickyNoteImport.dll
[DEBUG 21:20:54.817] StickyNoteImporter: Sticky Notes XML file does not exist or is invalid!
[DEBUG 21:20:55.019] Unable to locate 'sshfs' in your PATH
[DEBUG 21:20:55.020] Unable to locate 'wdfs' in your PATH
[DEBUG 21:20:55.186] Tomboy remote control active.
[DEBUG 21:20:57.798] SyncThread using SyncServiceAddin: Tomboy Web
[DEBUG 21:20:57.815] Building web request for URL: https://one.ubuntu.com/notes//api/1.0/
[DEBUG 21:20:58.807] Building web request for URL: https://one.ubuntu.com/notes/api/1.0/user/
[DEBUG 21:20:59.207] 8
[DEBUG 21:20:59.210] Sync: GetNoteUpdatesSince rev 3
[DEBUG 21:20:59.215] Building web request for URL: https://one.ubuntu.com/notes/api/1.0/op/?include_notes=true&since=3
[DEBUG 21:20:59.592] Sync: 0 updates since rev 3
[DEBUG 21:20:59.598] Building web request for URL: https://one.ubuntu.com/notes/api/1.0/op/
[DEBUG 21:21:00.002] Sync: Uploading 64 note updates
[DEBUG 21:21:00.064] Building web request for URL: https://one.ubuntu.com/notes/api/1.0/op/
[DEBUG 21:21:00.474] Building web request for URL: https://one.ubuntu.com/notes/api/1.0/op/
[ERROR 21:21:01.318] Caught exception. Message: The remote server returned an error: (500) INTERNAL SERVER ERROR.
[ERROR 21:21:01.323] Stack trace for previous exception: at System.Net.HttpWebRequest.CheckFinalStatus (System.Net.WebAsyncResult result) [0x00000]
  at System.Net.HttpWebRequest.SetResponseData (System.Net.WebConnectionData data) [0x00000]
[ERROR 21:21:01.327] Rest of stack trace for above exception: at System.Environment.get_StackTrace()
   at Tomboy.WebSync.Api.OAuth.MakeWebRequest(RequestMethod method, System.String url, System.Collections.Generic.List`1 parameters, System.String postData)
   at Tomboy.WebSync.Api.OAuth.WebRequest(RequestMethod method, System.String url, System.String postData)
   at Tomboy.WebSync.Api.OAuth.Put(System.String uri, IDictionary`2 queryParameters, System.String putValue)
   at Tomboy.WebSync.Api.UserInfo.UpdateNotes(IList`1 noteUpdates, Int32 expectedNewRevision)
   at Tomboy.WebSync.WebSyncServer.CommitSyncTransaction()
   at Tomboy.Sync.SyncManager.SynchronizationThread()
[ERROR 21:21:01.327] Synchronization failed with the following exception: The remote server returned an error: (500) INTERNAL SERVER ERROR.
  at System.Net.HttpWebRequest.CheckFinalStatus (System.Net.WebAsyncResult result) [0x00000]
  at System.Net.HttpWebRequest.SetResponseData (System.Net.WebConnectionData data) [0x00000]

(tomboy:4295): GLib-CRITICAL **: g_source_remove: assertion `tag > 0' failed

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu tomboy Edit question
Assignee:
No assignee Edit question
Last query:
2010-09-12
Last reply:
2010-09-11

This sort of thing should generally be filed as a bug, not a question. But yeah, this is an error from the U1 server. Hopefully by Tomboy 1.4's release in Ubuntu 10.10 we will have better debugging output to specify what the error is so that we can give a better report to the U1 guys.

I don't know why you would be getting this repeatedly. Maybe the U1 guys will have an error in their server logs that matches up with the error you see in Tomboy.

If you file the bug against ubuntuone-servers that would probably be the best bet.

Josh Rummel (josh-rummel) said : #2

No worries. I attached my issue to bug 554313 which looked like the same problem. Thanks!

https://bugs.launchpad.net/bugs/554313

Talia <email address hidden> wrote:

>Your question #124832 on tomboy in ubuntu changed:
>https://answers.launchpad.net/ubuntu/+source/tomboy/+question/124832
>
> Linked to bug: #636170
> https://bugs.launchpad.net/bugs/636170
> "Tomboy gets error 500 from U1 servers during Sync"
>
>--
>You received this question notification because you are a direct
>subscriber of the question.

Can you help with this problem?

Provide an answer of your own, or ask Josh Rummel for more information if necessary.

To post a message you must log in.