can not synchronize tomboy notes with ubuntu one

Asked by dumpa


When trying to synchronize my tomboy notes with ubuntu one I get a "could not synchronize notes, check details"
There are no details. It used to work 2 days ago. I have tried rebooting, closing gnome-do. It doesn't work in any computer.
I used to synchronize with dropbox and had a similar problem sometimes. There is a temporary hidden file which locks the synchronization and in some occasions it stays there. When I had this problem I just deleted the file and everything used to work again. In ubuntu one I can't see this file, apparently it is located on a folder in which i have no access, or maybe it doesn't exist at all.

I'm not sure if i'm the only one suffering from this note synchronization issue.

Question information

English Edit question
Ubuntu tomboy Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Sandy Armstrong (sanfordarmstrong) said :

If there is a hidden file locking sync, then you are not following the instructions correctly. Please read the instructions on this wiki page:

Revision history for this message
dumpa (dumpita) said :

Thanks for the answer, I just followed the instructions again, as it was the same proccedure I did before.
It does not synchronize.
The issue with the sync lock was something I figured out when I was using dropbox. I'm guessing it is the same with ubuntu one, though I'm not sure if this is the problem.

After following the instructions the problem persist.

I'm using karmic by the way.

Revision history for this message
Sandy Armstrong (sanfordarmstrong) said :

There is no sync lock when you use the Tomboy Web sync backend, as directed in the instructions. If you start Tomboy from a terminal with `tomboy --debug` and attempt to sync, there may be useful output there that you could paste here to diagnose what's going on.

Revision history for this message
dumpa (dumpita) said :

This is the error at the end. There is a lot of output that looks like html code. I only copy the last bit.

[ERROR]: Synchronization failed with the following exception: Unexpected character '<' at [1:1]
  at Hyena.Json.Tokenizer.UnexpectedCharacter (Char ch) [0x00000]
  at Hyena.Json.Tokenizer.InnerScan () [0x00000]
  at Hyena.Json.Tokenizer.Scan () [0x00000]
  at Hyena.Json.Deserializer.CheckScan (TokenType expected, Boolean eofok) [0x00000]
  at Hyena.Json.Deserializer.Deserialize () [0x00000]
  at Tomboy.WebSync.Api.UserInfo.ParseJson (System.String jsonString) [0x00000]
  at Tomboy.WebSync.Api.UserInfo.GetUser (System.String userUri, IWebConnection connection) [0x00000]
  at Tomboy.WebSync.WebSyncServer.BeginSyncTransaction () [0x00000]
  at Tomboy.Sync.SyncManager.SynchronizationThread () [0x00000]

(/usr/lib/tomboy/Tomboy.exe:12974): GLib-CRITICAL **: g_source_remove: assertion `tag > 0' failed

Revision history for this message
Sandy Armstrong (sanfordarmstrong) said :

This is a known bug that occurs when the Ubuntu One server is either not responding, or has some other sort of error. If you get this repeatedly, I'd recommend asking in IRC or filing a bug, because it could indicate something is wrong with your account (if it's working for other people).

Revision history for this message
dumpa (dumpita) said :


Revision history for this message
Ahmad Gharbeia أحمد غربية (gharbeia) said :

I had the same problem.

In Tomboy 1.11.3 on Ubuntu 12.04 the URL popultaed by default in the "Server" field of the "Synchronization" tab of Tomboy Preferences is ""

Looking at /home/ahmad/.config/tomboy/tomboy.log I found:
[ERROR]: Failed to get Root resource Exception was: System.Net.WebException: The remote server returned an error: (404) Not Found.

It's obvious that the connection code concatenates "/api/1.0" to whatever URL is set in the UI, thus causing two consecutive slashes to be, eventually causing the request to fall.

I removed the trailing slash in the UI, i.e setting the "Server" to "" and I was able to connect.

The connection code should sanitise the URL.

This is strange because I use the same version of Ubuntu at my home computer and hadn't encountered this problem except on my work computer.