Virtual Box can not read underlying disk files

Asked by ealthuis on 2018-09-07

After upgrading to 18.04LTS, and also Virtual Box 5.2, I can not access VB files on the computer's hard drive. All during 16.04 there were no problems doing so.

In this upgrade, I used the same VDi file as was used bty 16.04, this should make all pathways available, but I can in no way connect to these files.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu thunderbird Edit question
Assignee:
No assignee Edit question
Solved by:
ealthuis
Solved:
2018-09-16
Last query:
2018-09-16
Last reply:
2018-09-08

If you use a bridged network you can access the hidden admin shares in Windows "over the network" because every drive is automatically shared in Windows (to me this is terrible security) then you can access it using the default file manager as if the host system was another PC on the network.

Should work.

If you want files pulling in to the guest then virtualbox does do this. There are how to guides on YouTube. You should also post on the virtualbox forum as well as here. It is closer to your issue.

ealthuis (ealthuis) said : #2

Since we are talking, I have this to ask:
I have an older version of VB, when I load it, it restores the screen but immediately stops with this message:

Failed to open a session for the virtual machine Windows 7 2016.

Unsupported version 6 of data unit 'hda' (instance #0, pass 0xffffffff) (VERR_SSM_UNSUPPORTED_DATA_UNIT_VERSION).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

This version worked flawlessly with the connection set to "NAT"

I will post to VB in a minute...

ealthuis (ealthuis) said : #3

The simple answer to this problem was to install "Guest additions" in Virtual Box