Thunderbird Latest Update Thunderbird 52

Asked by Ravindra Gullapalli on 2017-05-03

Hello,

I am using Ubuntu 16.04. My Thunderbird version shows as 45.8.0.

However in thunderbird website, it shows 52.1.0

Why the latest update is not coming to me?

I tried to add sudo add-apt-repository ppa:mozillateam/thunderbird-stable

It says this ppa is not available and suggesting to add sudo add-apt-repository ppa:mozillateam/thunderbird-next which is a PPA with beta versions.

Please suggest how to update thunderbird to the latest version.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu thunderbird Edit question
Assignee:
No assignee Edit question
Solved by:
Ravindra Gullapalli
Solved:
2017-05-06
Last query:
2017-05-06
Last reply:
2017-05-04

What is in the new version that you need so very badly?

Steven Maude (stevenmaude) said : #2

Can't speak for the original poster, but personally:

* Thunderbird updates usually contain several security fixes. The two subsequent versions released since the package version 45.8 are no exception (see advisory links in my bug report: https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/1687571)

* the Google OAuth login fix in 52.1. Google are testing and/or rolling out a new OAuth login page which has a broken "next" button in the Ubuntu package version of Thunderbird. Consequently, login for Google account users with 2FA/OAuth logins are broken in Thunderbird, unless you see the "old" style page. This has recently stopped me from logging into a mail account via Thunderbird; Mozilla bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1359297

Then I suggest you report a bug to highlight these points. It may get the package updated sooner rather than later

I didn't say that I want that immediately. I was just wondering why there is a gap of 7 versions between the existing version and the latest. As @Steven said, there may be security fixes and it will be good if we keep up-to-date to the official release.

Manfred Hampl (m-hampl) said : #5

Just a remark:
Some (or most or all?) of the vulnerabilities have been tackled in the upgrade to 45.8.0, see https://www.ubuntu.com/usn/usn-3233-1/

Richard Pendlebury (rich5851) said : #6

Its the Google OAuth fix that I'm desperate for in the 52.1 release. Currently I am unable to add meeting invites and it's a show stopper for my work computer.

Thunderbird got updated today. Thank you.

Steven Maude (stevenmaude) said : #8

That's confusing. I don't see that any packages have been updated after this question was first asked.

I am using Ubuntu 16.04 Today I got another update 52.1.1