Ubuntu

Clicking link in email does not open browser

Asked by Brian Railey on 2008-04-02

Clicking a link in an email (Thunderbird 2) does not open the browser (Firefox 3 (Beta 4)). Worked in Gutsy (with Firefox 2). Same email read in my windows machine verifies the link is good.

ProblemType: Bug
Architecture: i386
Date: Wed Apr 2 07:33:35 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/yelp
Package: yelp 2.22.0-0ubuntu3
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: yelp
Uname: Linux 2.6.24-12-generic i686

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu thunderbird Edit question
Assignee:
No assignee Edit question
Last query:
2008-04-02
Last reply:
2009-08-25
Brian Railey (brianscruisin) said : #1

The duplicate reporter has said that this bug does not occur for him anymore. Does it still occur for you?

Jens Jensen (marshaller) said : #3

I can't open link from my mail in firefox 3 beta 5

John Vivirito (gnomefreak) said : #4

Jens can you please confirm that in system>perffered apps you have firefox-3.0 in it or custom with firefox-3.0 added to it and thunderbird set as email. This is assuming you are on Ubuntu not Kubuntu since apport gave us yelp info.

Jens Jensen (marshaller) said : #5

Hi John

Thank you, that was the problem, it was not firefox as webbrowser.
once again thank you.

Draik (draik) said : #6

I am using Kubuntu 8.04 with Firefox 3 beta 5. Links in Thunderbird do nothing. My email and web browser defaults are set to Thunderbird and Firefox, respectively. This issue arose from the upgrade to 8.04 as it was not present with 7.10. I have tried many things suggested here and in #Kubuntu.

Don_Alfonso (k-dietrich) said : #7

Same to me, Draik. And moreover pdf files can only be opened once, when I try to open another pdf ( or the same again) it says
"xy.pdf could not be opened, because the associated helper application does not exist...."
Default applications are correct, as far as I can see.

Clem (the-moffatts) said : #8

Hi All,

I have been unable to click on any links in Thunderbird since Kubuntu 8.04, and have any of them work. I have to copy and paste them directly into Firefox. I have tried to play around with the preferences in Thunderbird, but it did not make any difference. I am using Firefox 2.0.0.15, and Thunderbird 2.0.0.14, in Kubuntu 8.04.1, and it is frustrating that this isn't at a higher priority for fixing. It has been happening since Kubuntu 8.04, and I am running 3.5.9 KDE not 4.

jmtash (jmtash) said : #9

Sounds as though this problem has already been reported with the exception that HELP can't be selected either. https://bugs.launchpad.net/token/CljM8FzWwxrDbt2m7zb1

jmtash (jmtash) said : #10

I followed the advice found in this forum ( Rui Pais, via Michael "TheZorch" Haney) and updated the Thunderbird config statement to designate Firefox the HTTP link handler and it worked. The question remains: what happened that it was absent?

I had the same trouble when i upgrade from Gutsy to Hardy, i was using FF3 beta 4 and Thunderbird 2. Now i found a solution:
1.- Close both apps.
2.- Locate the ~/.mozilla-thunderbird/xxxxxx.profile/ directory, where xxxxxx are a chain of numbers and characters.
3.- Find the file prefs.js open and add the next three lines:

user_pref("network.protocol-handler.app.http", "/usr/bin/firefox");
user_pref("network.protocol-handler.app.https", "/usr/bin/firefox");
user_pref("network.protocol-handler.app.ftp", "/usr/bin/firefox");

4.- Save, close and test.

I founded here: http://www.forosdelweb.com/f41/como-howto-integrar-mozilla-thunderbird-con-mozilla-firefox-312158/

Draik (draik) said : #12

Similar to Mauricio Penaloza's post, you can do this within Intrepid Ibex by going to Edit > Preferences.

Click on the Advanced tab, then on Config Editor...

Search for a key:
network.protocol-handler.app.http

If it does not exist, you can right-click and create a new String.
The value of the string should be your absolute path to firefox:
/usr/bin/firefox

Close the Config Editor and it will start working instantly.

Poliltimmy (poliltimmy) said : #13

  I have done every step mentioned still no luck. tbird will not launch firefox2. I have tried to completely remove and fresh installs. After an hour of uninstalling and trying each solution on a fresh install I must come to the conclusion that Ubuntu does not take this seriously. And neither does Mozilla.

Ubuntu 8.04.1 AMD 64
Firefox 2 (out of the repos)
Tbird (out of repos)

  Since all come from Ubuntu repros, why they will not work together baffles me. Could have removing Evolution from my system caused this?

Poliltimmy (poliltimmy) said : #14

 The Thuderbrowse extension will work, kind of. It's a bit awkward but the links will open inside Tbird . The right click: Visit in Browser does not work on my machine. The other options are working fine. And fast too. I guess I can live with it.

Draik (draik) said : #15

I'm running Kubuntu 8.10 Intrepid Ibex

apt-cache policy firefox
firefox:
  Installed: 3.0.4+nobinonly-0ubuntu0.8.10.1

apt-cache policy thunderbird
thunderbird:
  Installed: 2.0.0.18+nobinonly-0ubuntu0.8.10.1

The solution to this problem:

I had the same trouble when i upgrade from Gutsy to Hardy, i was using FF3 beta 4 and Thunderbird 2.
1.- Close both apps.
2.- Locate the ~/.mozilla-thunderbird/xxxxxx.profile/ directory, where xxxxxx are a chain of numbers and characters.
3.- Find the file prefs.js open and add the next three lines:

user_pref("network.protocol-handler.app.http", "/usr/bin/firefox");
user_pref("network.protocol-handler.app.https", "/usr/bin/firefox");
user_pref("network.protocol-handler.app.ftp", "/usr/bin/firefox");

4.- Save, close and test.

I founded here: http://www.forosdelweb.com/f41/como-howto-integrar-mozilla-thunderbird-con-mozilla-firefox-312158/

Poliltimmy (poliltimmy) said : #17

I could not get it to work in 64 bit version Ubuntu after trying all of everyones advised. So since I keep all my Data on a separate partition, I installed the 32 bit Ubuntu and all seems fine now. I also left evolution in as my problems started when it was removed. Is evolution a must have in Ubuntu in the Gates style?

Though I prefer FF2, because of extension compatibility problems, I an afraid to remove FF3 as I do not want to break it again. IF FF3 ever comes out of beta, it appears it will be good, Mozilla is stating to remind me of Google and their never ending betas.

                                                                                       Thanks, Timmy

billmac333 (billmac333) said : #18

The prefs.js file edit may work, but you definitely need to have Thunderbird shut down.
Instead, you can use the gui to add a/the key/s to the config.
In Thunderbird, goto:
Edit -> Preferences -> Advanced -> Config Editor
You can right click and go New String
The enter that network.protocol-handler.app.https or http or ftp as you wish. Then it will prompt you for a value. Just enter your firefox binary, probably /usr/bin/firefox
Worked like a charm for me.

I had the same problem and found a solution.

The custom preferred browser under System-Preferred Applications - Web Browser had Firefox-3.5 %u the same as the command in my desktop link. I think I got it by looking at the preferences in the desktop link to start with.

I noticed that under Preferred applications the listing for Thunderbird had %s. When I changed the Firefox command to %s it worked properly.

I don't understand why the desktop icon has a "command" of Firefox-3.5 %u and the preferred application listing only works with a command of Firefox-3.5 %s but at least it works that way on my Ubuntu machine.

My solution was to go to Config Editor in Thunderbird and clear (reset) the following keys:-
  network.protocol-handler.app.http
  network.protocol-handler.app.https

Menu: Edit -> Preferences -> Advanced -> Config Editor

Right click on the keys mentioned above and clear them by selecting "Reset"

That did the trick for me.

Poliltimmy (poliltimmy) said : #21

Works fine now thanks rudd!!!!!

Can you help with this problem?

Provide an answer of your own, or ask Brian Railey for more information if necessary.

To post a message you must log in.