Cannot send email via thunderbird

Asked by TWFJR on 2013-03-09

Sending message failed . . . connecting to SMTP server smtp.acsalaska.net failed. Contacting ACSALASKA support idicated that all settings were correct. They could not solve the problem. No passwords are used and GMAIL passwords have been removed. Seems as if Thunderbird has this problem but I find no one offering a solution. What will solve sending email via Thunderbird?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu thunderbird Edit question
Assignee:
No assignee Edit question
Solved by:
TWFJR
Solved:
2013-03-09
Last query:
2013-03-09
Last reply:
2013-03-09
Thomas Krüger (thkrueger) said : #1

At first let's check if you can connect to the server from your machine. Please open the Terminal Application and run the following command. It might be a good idea to copy/paste the line into the Terminal.

telnet smtp.acsalaska.net 25

Then copy the output for us! You can exit the session by pressing Ctrl + ] and then entering QUIT at the prompt.
Also I'd like to see your configuration. You can extract it with this command:

fgrep smtpserver ~/.thunderbird/*.default/prefs.js

There will be no passwords included, but it might be a good idea to x-out the username. Thanks!

TWFJR (tom-fiechtl) said : #2

tom@tom-desktop:~$ telnet smtp.acsalaska.net 25
Trying 209.112.168.122...
telnet: Unable to connect to remote host: No route to host

tom@tom-desktop:~$ fgrep smtpserver ~/.thunderbird/*.default/prefs.js
user_pref("mail.append_preconfig_smtpservers.version", 2);
user_pref("mail.smtpserver.smtp1.authMethod", 1);
user_pref("mail.smtpserver.smtp1.description", "");
user_pref("mail.smtpserver.smtp1.hostname", "smtp.acsalaska.net");
user_pref("mail.smtpserver.smtp1.port", 25);
user_pref("mail.smtpserver.smtp1.try_ssl", 0);
user_pref("mail.smtpserver.smtp1.username", "");
user_pref("mail.smtpservers", "smtp1");

Thanks for your assist.

what is the output of:

ping -c 4 smtp.acsalaska.net; lsb_release -a; uname -a

Thanks

TWFJR (tom-fiechtl) said : #4

tom@tom-desktop:~$ ping -c 4 smtp.acsalaska.net; lsb_release -a; uname -a
PING smtp.acsalaska.net (209.112.168.122) 56(84) bytes of data.
64 bytes from smtp.acsalaska.net (209.112.168.122): icmp_req=1 ttl=53 time=48.2 ms
64 bytes from smtp.acsalaska.net (209.112.168.122): icmp_req=2 ttl=53 time=47.3 ms
64 bytes from smtp.acsalaska.net (209.112.168.122): icmp_req=3 ttl=53 time=48.4 ms
64 bytes from smtp.acsalaska.net (209.112.168.122): icmp_req=4 ttl=53 time=49.5 ms

--- smtp.acsalaska.net ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3002ms
rtt min/avg/max/mdev = 47.361/48.424/49.581/0.789 ms
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.10
Release: 12.10
Codename: quantal
Linux tom-desktop 3.5.0-25-generic #39-Ubuntu SMP Mon Feb 25 19:02:34 UTC 2013 i686 i686 i686 GNU/Linux

Thomas Krüger (thkrueger) said : #5

How do you connect to the internet? Who's your provider? Is it possible they are blocking SMTP connections?

TWFJR (tom-fiechtl) said : #6

I connect to the internet via acsalaska.net. I talked to them for a long time yesterday. I will call them back and speak about their possible blocking of SMTP connections.

TWFJR (tom-fiechtl) said : #8

I've talked to John at ACS technical support and configuration is correct and ACS is not blocking SMTP although the message is failed connection with smtp.acsalaska.net. I am in agreement with ACS that the issue is with Thunderbird.

Thomas Krüger (thkrueger) said : #9

No, it's not. IF it would be an issue with thunderbird the telnet command would have worked.
From the link Andrew posted and specifically the paragraph below the box I can extract, that there is some kind of blocking SMTP, at least from outside of ACS.

It it possible you are not connecting via ACS? Maybe you accidentally connected to your neighbor's WiFi?
To see that, please post the output of this command:

tracepath smtp.acsalaska.net

Thanks!

Thomas Krüger (thkrueger) said : #10

Please also give the output of

sudo iptables -L; sudo netstat -npl4

It will ask for your password, don't worry! It is only to list some information only the admin has access to.

TWFJR (tom-fiechtl) said : #11

Ok, let's go ahead and close this thread. The problem was with ACS having disconnected my accounts after our home burned. Thanks all for your assistance.