Thunderbird does not delete .parentlock file

Asked by hemantkarandikar on 2012-06-18

I am on Ububtu 12.04.

Afte I launch Thunderbird (TB) .parentlock file gets created in my mail folder. profile.ini has correct entries for the profile.

This file should get deleted when I close down TB. This doen't happen and prevents restart of TB unless I manually delete the file.

Any solution?

(My mail folder is on NTFS partition and it is auto mounted when I start Ubuntu 12. This used to work well under Ubuntu 11)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu thunderbird Edit question
Assignee:
No assignee Edit question
Solved by:
Sam_
Solved:
2012-06-25
Last query:
2012-06-25
Last reply:
2012-06-20
Sam_ (and-sam) said : #1

#2 described a similar issue.
bug 251749
Another one there.
http://ubuntuforums.org/showthread.php?t=1631513

So maybe a static entry for ntfs partition in /etc/fstab helps.
https://help.ubuntu.com/community/Fstab

Sam_ (and-sam) said : #2

If fstab entry doesn't help maybe some profile doesn't provide a clean shutdown of thunderbird. Web query finds lots of entries with .parentlock issues.
http://kb.mozillazine.org/Profile_in_use

I am not confident of changing fstab myself. I will need help.
The following are my devdevice ids

/dev/sda1: UUID="152E87F73B46A78D" TYPE="ntfs"
/dev/sda5: LABEL="New Volume" UUID="BC64ED3964ECF754" TYPE="ntfs"
/dev/sda6: UUID="41552315-cad4-4bd1-9d60-f72d678b5971" TYPE="swap"
/dev/sda7: UUID="6066303e-1eff-43f6-acc4-85b570d503b0" TYPE="swap"
/dev/sda8: UUID="74515057-edfd-4937-9ca0-96fab81d0ba3" TYPE="ext4"

I guess I need to add a static entry to fstab for /dev/sda5 (this has my mail folder). What entry should I add in fstab?

Thanks

Best Sam_ (and-sam) said : #4

There're some examples in the link posted in #1, just replace them with your data and adjust as preferred.
Make a backup from fstab and view entries as example.
e.g.
[Device] [Mount Point] [File System Type] [Options] [Dump] [Pass]
## /dev/sda5
UUID=BC64ED3964ECF754 <mount_point> ntfs defaults,locale=en_US.utf8 0 0

or
## /dev/sda5
UUID=BC64ED3964ECF754 <mount_point> ntfs auto,users,uid=1000,gid=100,dmask=027,fmask=137,utf8 0 0

or
## /dev/sda5
UUID=BC64ED3964ECF754 <mount_point> ntfs defaults,nls=utf8,umask=007,gid=46 0 0

Thanks Sam_, that solved my question.