Problem in installing TeXLive backported to Precise

Asked by Shriramana Sharma on 2012-05-25

I came to know about the TeX Live backports PPA from I got to know about this PPA from https://bugs.launchpad.net/ubuntu/+source/texlive-base/+bug/712521.

I have in my /etc/apt/sources.list.d/ a file with the entry:

deb http://ppa.launchpad.net/texlive-backports/ppa/ubuntu precise main

I do *not* have the stock Ubuntu Precise texlive packages installed. My repo lists are up-to-date.

I am trying to install the backported texlive. But I get the following error:

<quote>
$ sudo apt-get install texlive
[samjnaa:/etc/apt/sources.list.d] sagi texlive
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 texlive : Depends: texlive-fonts-recommended (>= 2012.20120516) but it is not going to be installed
           Depends: texlive-latex-recommended (>= 2012.20120516) but it is not going to be installed
           Depends: texlive-latex-base (>= 2012.20120516) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
</quote>

I tried to install all those dependency packages by mentioning them individually:

<quote>
$ sudo apt-get install texlive texlive-fonts-recommended texlive-latex-recommended texlive-latex-base
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 texlive-fonts-recommended : Depends: texlive-common (>= 2012.20120516-1) but 2012.20120516-1~precise1 is to be installed
                             Depends: texlive-base (>= 2012.20120516) but it is not going to be installed
                             Recommends: texlive-fonts-recommended-doc but it is not going to be installed
                             Recommends: tipa (>= 2:1.2-2.1) but it is not going to be installed
                             Recommends: tex-gyre but it is not going to be installed
 texlive-latex-base : Depends: texlive-common (>= 2012.20120516-1) but 2012.20120516-1~precise1 is to be installed
                      Depends: texlive-base (>= 2012.20120516) but it is not going to be installed
                      Recommends: texlive-latex-base-doc but it is not going to be installed
 texlive-latex-recommended : Depends: texlive-common (>= 2012.20120516-1) but 2012.20120516-1~precise1 is to be installed
                             Recommends: texlive-latex-recommended-doc but it is not going to be installed
                             Recommends: prosper (>= 1.00.4+cvs.2006.10.22-1) but it is not going to be installed
                             Recommends: latex-beamer (>= 3.06.dfsg.1-0.1) but it is not going to be installed
                             Recommends: latex-xcolor (>= 2.09-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
</quote>

Again I tried:

<quote>
$ sudo apt-get install texlive texlive-fonts-recommended texlive-latex-recommended texlive-latex-base texlive-common texlive-base
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 texlive-base : Depends: texlive-common (>= 2012.20120516-1) but 2012.20120516-1~precise1 is to be installed
                Depends: texlive-doc-base (>= 2012.20120516) but it is not going to be installed
                Depends: texlive-binaries (>= 2012.20120516-1) but 2012.20120516-1~precise1 is to be installed
                Recommends: lmodern (>= 0.93.3-1) but it is not going to be installed
 texlive-fonts-recommended : Depends: texlive-common (>= 2012.20120516-1) but 2012.20120516-1~precise1 is to be installed
                             Recommends: texlive-fonts-recommended-doc but it is not going to be installed
                             Recommends: tipa (>= 2:1.2-2.1) but it is not going to be installed
                             Recommends: tex-gyre but it is not going to be installed
 texlive-latex-base : Depends: texlive-common (>= 2012.20120516-1) but 2012.20120516-1~precise1 is to be installed
                      Recommends: texlive-latex-base-doc but it is not going to be installed
 texlive-latex-recommended : Depends: texlive-common (>= 2012.20120516-1) but 2012.20120516-1~precise1 is to be installed
                             Recommends: texlive-latex-recommended-doc but it is not going to be installed
                             Recommends: prosper (>= 1.00.4+cvs.2006.10.22-1) but it is not going to be installed
                             Recommends: latex-beamer (>= 3.06.dfsg.1-0.1) but it is not going to be installed
                             Recommends: latex-xcolor (>= 2.09-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
</quote>

Look at the entries for texlive-common and texlive-binaries. It seems silly that the system doesn't recognize that 2012.20120516-1~precise1 is acceptable for >= 2012.20120516-1.

Is there something I have to do to fix this? Or should I just wait for any fresh packages with updated dependencies to build?

Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu texlive-base Edit question
Assignee:
No assignee Edit question
Solved by:
Jeremy Bicha
Solved:
2012-05-26
Last query:
2012-05-26
Last reply:
2012-05-26

I suggest you contact the ppa maintainer as s/he has built the files with later packages than you have available.

Shriramana Sharma (jamadagni) said : #2

Thank you. I have already contacted the PPA maintainer and pointed them to this publicly visible question. I didn't want to bother them with full details on a private mail and I wanted to ensure that their answer will be public. I hope they will reply on this thread soon.

Best Jeremy Bicha (jbicha) said : #3

Hi, I think this is fixed now. The texlive dependencies were set too high for backports to work easily like they should. Try running sudo apt-get update and let me know if you still are having problems.

Shriramana Sharma (jamadagni) said : #4

Thanks Jeremy! I did apt-get update and am now downloading the packages without any dependency problems. :-)