After windows faillure 1st (windows) HDD broke n ubuntu cant mount 2nd (Storage) HDD

Asked by StevenField on 2009-06-12

When my system became really slow I rebooted and after that windows didnt start op again and then got an error that windows coudnt boot. So tried installing windows again but couldnt find my 1st (windows) HDD, only my storage HDD.

Luckely I had an Ubuntu disk lying around and booted from that but Ubuntu cant mount the storage HDD. It says "logfile indicates unclean shutdown (0, 0) Failed to mount '/dev/sda1': Operation not supported Mount is denied because NTSF is marked to be in use. Choose one action: Choice 1: If you have windows then disconnect the external devices by clicking on the 'Safely Remove Hardware' icon in the windows taskbar then shutdown windows cleanly. Choice 2: If you dont have windows then you can use the 'force' option for your own responsibility. For example type on the command line: mount -t ntfs-3g /dev/sda1 /media/storage -o force Or add the option to the relevant row in the /etc/fstab file: /dev/sda1 /media/Storage ntfs-3g defaults,force 0 0".

Then I tried to type "mount -t ntfs-3g /dev/sda1 /media/storage -o force" in the terminal but got another error. It says "Only root can do that".

Now I dont know what to do....????????......?????

Does somebody know what to do?

BTW: Disconnected my 1st (windows) HDD since its probably broken, now there's only the storage HDD in my PC.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu testdisk Edit question
Assignee:
No assignee Edit question
Last query:
2009-06-12
Last reply:
2009-06-12
Andre Mangan (kyphi) said : #1

So you want to access your storage drive using a live Ubuntu CD. Type this in a terminal and press Enter:

sudo mount -t ntfs-3g /dev/sda1 /media/storage -o force

Can you help with this problem?

Provide an answer of your own, or ask StevenField for more information if necessary.

To post a message you must log in.