External hard drive and Ubuntu.

Asked by Ganesh on 2009-02-02

Hello,

I need some help in accessing data from my external hard drive.

I have an iomega external hard drive with 500 Gig space. I was using it to save my files. I used to log in Windows XP and copy many files for the last three months. Then I copied a folder from Ubuntu on to that external hard drive. It looks like the file system on the external hard drive is messed up when Ubuntu tried to copy a folder to it. Now I am not able to read the contents of the external hard drive either from Windows XP SP2 or from Ubuntu 6.06 . Both Windows XP and Ubuntu is able to detect the external hard drive. Windows is forcing me to format the external hard drive, maybe because it is not able to detect the file system.

I am not able to see the files on the external hard drive from Ubuntu either. From Ubuntu computer file browser window, the external hard drive does not appear. I was able to successfully read the external drive from Ubuntu also about ten days back. Ten days back, when I accessed the external the external hard drive successfully, I copied a folder from Ubuntu local hard drive to the external hard drive. Maybe that was a mistake. I am surprised to even think that Ubuntu can mess up the existing file system on the external hard drive.

How can I recover the data stored in the external hard drive? What would be the right forum to ask for help on recovering files from external hard drive? The iomega support person is not able to help me. The external drive is still in warranty.

Thanks and regards,
Ganesh

The source package you found the bug in, for help see https://wiki.ubuntu.com/Bugs/FindRightPackage .

1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu.
Ubuntu 6.06 LTS - the Dapper Drake

2) The version of the package you are using, via 'apt-cache policy packagename' or by checking in Synaptic.

3) What you expected to happen?: To read files from external hard drive.

4) What happened instead?: Not able to read files from external hard drive. Coundn't display "/dev/sda"in file browser

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu testdisk Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
2009-02-06
Last query:
2009-02-06
Last reply:
2009-02-02

This question is now associated to "testdisk" package.

I suggest you to click on this launchpad page tabs:

- the "Answers" tab will allow you to see all already answered questions related to this package;

This might helps you to solve your issue, by the way is a good starting point.

Try to use testdisk... is wonderful to access damaged partitions and get data back.

Hope this helps

Tom (tom6) said : #2

I think it probably is possible to recover the data. Don't worry!

Ganesh (venkat-ganesh43016) said : #3

Thanks marcobra and Tom. I was able to recover data using testdisk. After scanning my external hard drive, testdisk reported that the FAT32 boot sector was corrupted and it gave me an option to copy it from backup. I was able to copy the directories from the external hard drive to c drive using testdisk. Thank you very much. Have a wonderful day.

Ganesh (venkat-ganesh43016) said : #4

Thanks marcobra, that solved my question.