files retrieved with photorec should be mostly pictures, but appear to be txt files

Asked by ken machen on 2011-09-17

I have an external hard drive that we stored our pictures on. Well after installing ubuntu i thought that i could boot off of the partition that I made. So i went into the bios and had it load from what i thought was the partition and tried to run system restore on what turned out to be the external drive.
the computer didn't even recognize it any more. i took it to the shop down the road and they said to send it to a data recovery service. i decided to see what i could find online about it.
i found someone that used photorec and testdisk and got all the pictures back.
i ran photorec and got a bunch of stuff, but it looks like the pictures were somehow converted to txt files.

how do i convert them back to photos? Orwhat can i do to recover them correctly?

i also ran testdisk to try and repair the partitions i got two to show up, but the main one(with pics) won't mount.
i get this message
Error mounting: mount exited with exit code 13: ntfs_mst_post_read_fixup: magic: 0x15030e07 size: 4096 usa_ofs: 8705 usa_count: 5381: Invalid argument
Actual VCN (0x322113536331013) of index buffer is different from expected VCN (0x5).
Failed to mount '/dev/sdg1': Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu testdisk Edit question
Assignee:
No assignee Edit question
Last query:
2011-09-17
Last reply:
2011-09-17

Use your backups is all I can advise. Could try opening them in Windows.

Can you help with this problem?

Provide an answer of your own, or ask ken machen for more information if necessary.

To post a message you must log in.