Problems with TclMagick0.45 build for Ubuntu 9.10

Asked by jack mai

I am Linux novice and have a probably trivial problem with installing TclMagick0.45 on Ubuntu9.10 running on Intel Core 2 Quad Q8200, 4GB.

I have been using installation instructions from <>. and are in /opt/ActiveTcl-8.5/lib/. I have extracted and placed folder TclMagick-0.45 into /opt.

I can not locate

Synaptic Package Manager shows that imagemagick package is installed with latest version 7: My best guess is that it is in /usr/lib/ImageMagick-6.5.1/ where I have found configure.xml with what seems to be configuration info. For completeness, I am attaching here the list of installed files reported by Synaptic Package Manager:


To install the tclMagick I have used the following commands

    ./configure --with-tcl=/opt/ActiveTcl-8.5/lib/ --with-tk=/opt/ActiveTcl-8.5/lib/ --with-magick=/usr/lib/ImageMagick-6.5.1/

to make it simpler I have skipped --enable-shared. Once configured I executed


make generates a lot of warning and errors and is terminated by the following:

   ... errors and messages
   make[1]: *** [libTclMagick_la-TclMagick.lo] Error 1
   make[1]: Leaving directory `/opt/TclMagick-0.45/generic'
   make: *** [all-recursive] Error 1

I would appreciate any hints how to install the TclMagick0.45 build for Ubuntu 9.10. I have it running on Windows7 with no major problems and right now I am just porting the scripts to Linux. Great program. Perhaps it could have been a bit more popular with easier installation process ;-)

By the way how one can make it thread aware - I have seen the following message:
configure: WARNING:
    Building TclMagick without threads enabled, but building against a Tcl
    that IS thread-enabled.

Thanks for help,


Question information

English Edit question
Ubuntu tclmagick Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Launchpad Janitor (janitor) said :

This question was expired because it remained in the 'Open' state without activity for the last 15 days.