tasksel, install LAMP

Asked by Hamidjon Imomov on 2012-08-01

Hi,
My tasksel is not working properly. In a site (http://www.unixmen.com/install-lamp-with-1-command-in-ubuntu-1010-maverick-meerkat/) the steps about installing the LAMP by one command (sudo tasksel) is explained. I'm having trouble in a first step: when I enter 'sudo tasksel' to a command line, the tasksel shows only one line at Software selection:
______________________________________________________
Choose software to install:
   [ ] Manual package selection
        <ok>
______________________________________________________

Just one, no more available selections. According to site, here, must be ([ ] LAMP), but there is no such line. Can somebody help to solve this problem? Thanks.

At first time, when I used 'sudo tasksel' there were 3 selection-lines (first and second already checked and third one not unchecked). I unchecked first and second and selected the third one and hit <ok>... Maybe, here, I made a mistake ...

Commands (such as lsb_release -a; echo; apt-cache policy tasksel) give:
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise

tasksel:
  Installed: 2.88ubuntu9
  Candidate: 2.88ubuntu9
  Version table:
 *** 2.88ubuntu9 0
        100 /var/lib/dpkg/status

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu tasksel Edit question
Assignee:
No assignee Edit question
Solved by:
Hamidjon Imomov
Solved:
2012-08-02
Last query:
2012-08-02
Last reply:
2012-08-01

Is the system fully updated?

Finally I solved it: I changed some settings in Ubuntu Software Center (Edit->Software Sources) and then all packages started to dwnld.