tar: This does not look like a tar archive tar: Skipping to next header tar: Error exit delayed from previous errors

Asked by Jeff the novice on 2009-08-01

I'm having problems in installing tar based programs as I keep getting the above error message in archive manager I m' running Ubuntu 9.04 on a Fujitsu siemens c series lifebook

The tar files are high quality including the Firefox 3.05 instalation file can anybody help mPlease

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu tar Edit question
Assignee:
No assignee Edit question
Solved by:
Larry Jordan
Solved:
2009-08-15
Last query:
2009-08-15
Last reply:
2009-08-05
Larry Jordan (larryjor) said : #1

     Sounds like you are following the usual instructions and extracting using the tar command.... I gave up on that myself. Open it with Archive Manager or Ark, which keeps you in a window. From there it will show you everything that is in the tar archive and you can extract it to whatever location from the window. So basically, just browse for it under "Places->Home"... whereever you downloaded it to and right click on it.
     I seldom had any luck with the 'tar -x...' commands.

Jeff the novice (j-m-fletcher) said : #2

Thanks I have already tried to use Archive Manager directly using right click but it produced the same answer I have downloaded ARK and this produces the following error message:-

Reading the archive '/home/jeffery/Downloads/hamachi-0.9.9.9-20-lnx.tar.gz' failed with the error 'The archive reading failed with message: Unrecognized archive format: Invalid or incomplete multibyte or wide character'

It therefore seems there is something more fundamentally wrong

Please tell the command you type to untar the file...?

tar -xzvf hamachi-0.9.9.9-20-lnx.tar.gz

Can you provide us the web link where you have downloaded the file...

Thank you

Jeff the novice (j-m-fletcher) said : #4

The link is http://files.hamachi.cc/linux

However I have the same problem with the file for Mozilla Thunderbird as follows:-

Reading the archive '/home/jeffery/Downloads/thunderbird-2.0.0.22.tar.gz' failed with the error 'The archive reading failed with message: Unrecognized archive format: Invalid or incomplete multibyte or wide character'

I tried the Terminal command as suggested and it returned the following:-

effery@jeffery-laptop:~/Downloads$ tar -xzvf hamachi-0.9.9-20-lnx.tar.gz
tar: hamachi-0.9.9-20-lnx.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors

Thank you

Larry Jordan (larryjor) said : #5

     It sounds like this was a bad TAR file. Have you had success with others?

Jeff the novice (j-m-fletcher) said : #6

Not with the gz in the end but I have been abls e to open the same file on an Acer Netbook running Linpus Linux Lite

Best Larry Jordan (larryjor) said : #7

     Not that I am much good with it, since mine on my old FC2 system NEVER worked and I got used to using the ARK in window mode, but have you tried removing the gzip separately using something like gzip hamachi-0.9.9-20-lnx.tar.gz or gzip -d hamachi-0.9.9-20-lnx.tar.gz? That should leave you with a straight TAR file to work on. (TAR is supposed to be able to do the decompression anyway, but since you mentioned that you haven't had success with files ending in .gz I'm wondering if maybe it'll fix this for you.)

Jeff the novice (j-m-fletcher) said : #8

Hi I'm sorry to have taken so long to reply but I've been on holiday and only recently connected my computer yes his has solved my problem thanks using the -d command

Jeff the novice (j-m-fletcher) said : #9

Thanks Larry Jordan, that solved my question.