system-config-samba

Asked by dln949 on 2017-08-23

Trying to run system-config-samba on 17.04 (it worked fine for me on 16.10), here is terminal output:

main1@system1:~$ gksu system-config-samba
  File "/usr/sbin/system-config-samba", line 45, in <module>
    mainWindow.MainWindow(debug_flag)
  File "/usr/share/system-config-samba/mainWindow.py", line 82, in __init__
    self.samba_data = sambaParser.SambaParser(self)
  File "/usr/share/system-config-samba/sambaParser.py", line 185, in __init__
    self.parseFile ()
  File "/usr/share/system-config-samba/sambaParser.py", line 225, in parseFile
    token = self.createToken (line, section)
  File "/usr/share/system-config-samba/sambaParser.py", line 310, in createToken
    name, value = line.split ("=", 1)
ValueError: need more than 1 value to unpack
main1@system1:~$

I do not know what this means, nor how to fix the problem. I've searched, but found nothing. (Although, I am not sure of the correct search terms to use.)

I am hoping someone can help me with understanding these messages and fixing it so system-config-samba works. Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu system-config-samba Edit question
Assignee:
No assignee Edit question
Solved by:
dln949
Solved:
2017-08-25
Last query:
2017-08-25
Last reply:
2017-08-24

Are there any bugs reported?

What are you trying to achieve? We may be able to advise.

dln949 (goodstuff9) said : #2

I am not aware of any bugs reported for this, I was not able to find any.

I was trying to use system-config-samba as a GUI tool to modify samba settings.

Yes, modify them to achieve what end?

Manfred Hampl (m-hampl) said : #4

It is strange that this program would have worked in Ubuntu 16.10, but no more works in 17.04, because the package versions in these releases are identical.

For me the error message looks as if there is a wrong entry in the /etc/samba/smb.conf configuration file.
What are its contents?

dln949 (goodstuff9) said : #5

To actionparsnip's question in post #3 above:

I was going to add a new share.

dln949 (goodstuff9) said : #6

To Manfred Hampl's comment #4 above:

I think you may be correct. I did not think the two would be related. So, after initially posing this question on Launchpad, I made several changes to smb.conf. I don't know which change fixed things, but now system-config-samba works.