system-config-printer problem

Asked by Marshall Levin on 2007-03-20

I'm using Xubuntu 6.10. I'm logged in as normal user. From "Applications" menu, I choose "Settings" and then from the submenu, I choose "Printing" (which, incidentally, has no icon).

Then a prompt says "Password required. Password for root on localhost?" Of course by default there is no root password, so nothing I type here works (including my own password) and all I can do is cancel.

If I set a root password, this works fine. If I open a terminal and type "sudo system-config-printer" this works fine. But when I choose it from the menu, it doesn't.

I believe the menu entry needs "gksudo" in front of it, but for the life of me I can't find where I edit the menu. It just seems to be included from some mysterious place. I don't see in my ~/.config/xfce4/desktop/menu.xml where this included menu comes from.

Can someone suggest a fix for this?

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu system-config-printer Edit question
Assignee:
No assignee Edit question
Solved by:
Mariano Mara
Solved:
2007-03-21
Last query:
2007-03-21
Last reply:
2007-03-21
Best Mariano Mara (marplatense) said : #1

Please, let me know if this works.
1- Search for *.desktop files (for the most part they're all @ /usr/share/applications/ but just in case do a slocate *.desktop to locate them all.
2- you should find the Printing file and edit it.
3- You should find there the command line where you can add the gksudo.

Marshall Levin (mlevin) said : #2

User confirmed that the request is solved.

Marshall Levin (mlevin) said : #3

That worked like a charm. The file I had to modify was /usr/share/applications/redhat-system-config-printer.desktop. I just changed the line with the command from:

Exec=/usr/bin/system-config-printer

to:

Exec=gksudo /usr/bin/system-config-printer

Will this be corrected in an upcoming release?

Mariano Mara (marplatense) said : #4

I didn't find a related bug in malone (this was as far as I got: https://bugs.beta.launchpad.net/ubuntu/+source/xfprint4/+bug/54436).
If you're interested, you can create a bug (in the left upper box of this page, click on "Create a bug Report") so it can be take in consideration by the developers.

Please, note, however, that this might not be an error but an intended behavior (on which I cannot comment for lack of knowledge). IMHO, it seems way too evident to have successfully avoided QA.

harpo (arpo1) said : #5

I've checked all the FAQs and followed all the routes as far as possible, because they are not as suggested, and I cannot print anything to my printer. Why does connecting a printer have to be so difficult? Why is it that the disc supplied with the printer doesn't work on ubuntu? - all it does is put a useless icon on the desktop!!!!

Another impossibility, it seems, is changing my password! If ubuntu is supposed to be so easy then why do I find it so difficult, and, judging by the FAQs, so does most everybody else!?

I'm going to leave ubuntu in my PC but I won't use it for a few months until it becomes more easy to understand. Meanwhile I'll stick with Microsoft.

Thank-you