i am unable to install any software or apps either from terminal or from package manager

Asked by Thooyavan on 2009-10-09

i am using ubuntu 9.04.15

i think it is the latest

i am unable to install any software or apps either from terminal or from package manager

i found out the reason correctly but just could not correct it

the problem is that both installation managers check the software in the site

http://in.archive.ubuntu.com/ubuntu/pool/universe/

but the below site supposed to be the correct one

http://in.archive.ubuntu.com/pool/universe/

it was from my system that the bug-#179338

pls help me out

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu synaptic Edit question
Assignee:
No assignee Edit question
Last query:
2009-10-09
Last reply:
2009-10-09
Thooyavan (thooyavan) said : #1

root@SecuredZone:~# yum
The program 'yum' is currently not installed. You can install it by typing:
apt-get install yum
-bash: yum: command not found
root@SecuredZone:~# apt-get install yum
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-2.6.28-11 linux-headers-2.6.28-11-generic
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libbeecrypt6 librpm4.4 python-celementtree python-elementtree python-rpm python-sqlite python-sqlitecachec python-urlgrabber rpm
Suggested packages:
  python-celementtree-dbg python-elementtree-doc python-sqlite-dbg alien
The following NEW packages will be installed:
  libbeecrypt6 librpm4.4 python-celementtree python-elementtree python-rpm python-sqlite python-sqlitecachec python-urlgrabber rpm yum
0 upgraded, 10 newly installed, 0 to remove and 0 not upgraded.
Need to get 2833kB of archives.
After this operation, 10.9MB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
  libbeecrypt6 librpm4.4 python-elementtree python-celementtree python-sqlite python-urlgrabber rpm python-rpm python-sqlitecachec yum
Install these packages without verification [y/N]? y
Err http://in.archive.ubuntu.com jaunty/main libbeecrypt6 4.1.2-7
  404 Not Found
Err http://in.archive.ubuntu.com jaunty/main librpm4.4 4.4.2.3-2ubuntu1
  404 Not Found
Err http://in.archive.ubuntu.com jaunty/universe python-elementtree 1.2.6-12
  404 Not Found
Err http://in.archive.ubuntu.com jaunty/universe python-celementtree 1.0.5-10
  404 Not Found
Err http://in.archive.ubuntu.com jaunty/universe python-sqlite 1.0.1-7ubuntu1
  404 Not Found
Err http://in.archive.ubuntu.com jaunty/main python-urlgrabber 3.1.0-4ubuntu1
  404 Not Found
Err http://in.archive.ubuntu.com jaunty/main rpm 4.4.2.3-2ubuntu1
  404 Not Found
Err http://in.archive.ubuntu.com jaunty/universe python-rpm 4.4.2.3-2ubuntu1
  404 Not Found
Err http://in.archive.ubuntu.com jaunty/universe python-sqlitecachec 1.1.2-1ubuntu1
  404 Not Found
Err http://in.archive.ubuntu.com jaunty/universe yum 3.2.21-1
  404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/b/beecrypt/libbeecrypt6_4.1.2-7_i386.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/r/rpm/librpm4.4_4.4.2.3-2ubuntu1_i386.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/universe/e/elementtree/python-elementtree_1.2.6-12_all.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/universe/c/celementtree/python-celementtree_1.0.5-10_i386.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/universe/p/python-sqlite/python-sqlite_1.0.1-7ubuntu1_i386.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/u/urlgrabber/python-urlgrabber_3.1.0-4ubuntu1_all.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/r/rpm/rpm_4.4.2.3-2ubuntu1_i386.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/universe/r/rpm/python-rpm_4.4.2.3-2ubuntu1_i386.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/universe/y/yum-metadata-parser/python-sqlitecachec_1.1.2-1ubuntu1_i386.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/universe/y/yum/yum_3.2.21-1_all.deb 404 Not Found
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
root@SecuredZone:~#

Thooyavan (thooyavan) said : #2

i am using ubuntu 9.04.15

i think it is the latest

i am unable to install any software or apps either from terminal or from package manager

i found out the reason correctly but just could not correct it

the problem is that both installation managers check the software in the site

http://in.archive.ubuntu.com/ubuntu/pool/universe/

but the below site supposed to be the correct one

http://in.archive.ubuntu.com/pool/universe/

it was from my system that the bug-#179338

pls help me out

root@SecuredZone:~# yum
The program 'yum' is currently not installed. You can install it by typing:
apt-get install yum
-bash: yum: command not found
root@SecuredZone:~# apt-get install yum
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-2.6.28-11 linux-headers-2.6.28-11-generic
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libbeecrypt6 librpm4.4 python-celementtree python-elementtree python-rpm python-sqlite python-sqlitecachec python-urlgrabber rpm
Suggested packages:
  python-celementtree-dbg python-elementtree-doc python-sqlite-dbg alien
The following NEW packages will be installed:
  libbeecrypt6 librpm4.4 python-celementtree python-elementtree python-rpm python-sqlite python-sqlitecachec python-urlgrabber rpm yum
0 upgraded, 10 newly installed, 0 to remove and 0 not upgraded.
Need to get 2833kB of archives.
After this operation, 10.9MB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
  libbeecrypt6 librpm4.4 python-elementtree python-celementtree python-sqlite python-urlgrabber rpm python-rpm python-sqlitecachec yum
Install these packages without verification [y/N]? y
Err http://in.archive.ubuntu.com jaunty/main libbeecrypt6 4.1.2-7
  404 Not Found
Err http://in.archive.ubuntu.com jaunty/main librpm4.4 4.4.2.3-2ubuntu1
  404 Not Found
Err http://in.archive.ubuntu.com jaunty/universe python-elementtree 1.2.6-12
  404 Not Found
Err http://in.archive.ubuntu.com jaunty/universe python-celementtree 1.0.5-10
  404 Not Found
Err http://in.archive.ubuntu.com jaunty/universe python-sqlite 1.0.1-7ubuntu1
  404 Not Found
Err http://in.archive.ubuntu.com jaunty/main python-urlgrabber 3.1.0-4ubuntu1
  404 Not Found
Err http://in.archive.ubuntu.com jaunty/main rpm 4.4.2.3-2ubuntu1
  404 Not Found
Err http://in.archive.ubuntu.com jaunty/universe python-rpm 4.4.2.3-2ubuntu1
  404 Not Found
Err http://in.archive.ubuntu.com jaunty/universe python-sqlitecachec 1.1.2-1ubuntu1
  404 Not Found
Err http://in.archive.ubuntu.com jaunty/universe yum 3.2.21-1
  404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/b/beecrypt/libbeecrypt6_4.1.2-7_i386.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/r/rpm/librpm4.4_4.4.2.3-2ubuntu1_i386.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/universe/e/elementtree/python-elementtree_1.2.6-12_all.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/universe/c/celementtree/python-celementtree_1.0.5-10_i386.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/universe/p/python-sqlite/python-sqlite_1.0.1-7ubuntu1_i386.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/u/urlgrabber/python-urlgrabber_3.1.0-4ubuntu1_all.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/r/rpm/rpm_4.4.2.3-2ubuntu1_i386.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/universe/r/rpm/python-rpm_4.4.2.3-2ubuntu1_i386.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/universe/y/yum-metadata-parser/python-sqlitecachec_1.1.2-1ubuntu1_i386.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/universe/y/yum/yum_3.2.21-1_all.deb 404 Not Found
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
root@SecuredZone:~#

Delan Azabani (azabani) said : #3

I'm not sure if this is just for yum, but if it is just for yum, why are you using yum for package management anyway? You already have APT, and you shouldn't really have two package management systems on your computer.

ronnie_libra (ronnie-libra) said : #4

i agree with Delan Azabani,but if you really want to install it u must first reseach about it.My be there's something you must do: Authentication key or Public key,edit your software sources or repository...my opinion is you you stay with APT

Delan Azabani (azabani) said : #5

Exactly. Ubuntu is built around the APT packaging system, so installing yum (rpm package manager) is arguably changing Ubuntu quite a bit.

zvacet (ivicakolic) said : #6

As ronnie_libra and Delan Azabani said there is no need for that package.But it look like it is something with source list or server.Sysstem>admin>software sources> change server and reload.If that doesn´t help type in terminal

cat /etc/apt/sources.list

and post output.

Can you help with this problem?

Provide an answer of your own, or ask Thooyavan for more information if necessary.

To post a message you must log in.