How do I get the download working on the system?

Asked by Matthew T. Allen on 2020-02-04

I haven't worked with unix for 40 years. I'm new to this installation process. My H/W platform is a simple, "Sky-Lake" without "bells-and-whistles". I've downloaded apps per instructions. I don't know how to invoke the installation of them. Simantic is one.. -It might make the other installations easier.. Got the files and don't know what to do next. (Thought I'd get an icon or something..)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu synaptic Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2020-02-08
Last query:
2020-02-08
Last reply:
2020-02-07

This question was reopened

You need to tell your BIOS to boot from the USB stick or CD you made. It's not a Windows or Mac application where you manually run setup.exe

Be sure to run a full update on the system you intend to install on incase of issues (unless the data on there has zero value to you)

YouTube have guides too. You may want to watch a few so you get an idea of what to expect.

The files are in my download directory. The system is ubuntu 18.04 already running (with no audio and a power-down problem). Much of YouTube content is audio (so, that doesn't work). I just want to get an AVR compiler and programmer running. Synaptic was suggested to simplify the install but, it's a "dead end" just like loading the apps..
All my BIOS settings are documented. I had to disconnect the CMOS battery and reload as the UEFI FLASH Memory had disabled USB ports for a faulty setting made before.. As the UEFI is poorly documented for an end user like me, I sure there could be another mistake under the pile of failure I see..
Thanks!

https://packages.ubuntu.com/xenial/gcc-avr

sudo apt-get install gcc-avr

Will install a compiler.

Manfred Hampl (m-hampl) said : #4

The easiest way to install programs is opening the "Ubuntu-Software" program. Inside that program you can search for available apps and install them.

If you are used to command line windows, then you also can open a terminal window (e.g. by simultaneously pressing ctrl-alt-t) and then issue the command
sudo apt install synaptic
to install the synaptic package management program.
(You will be asked for your password as confirmation for an administrative action, end when entering the password you will not get any feedback, no echo, not even '*' placeholders.)

I can see the the terminal load everything. I'll look for help activating it.
Thanks!

Gcc-avr is oriented toward "C language"" As such, it makes making a assembler (machine language) more difficult for me (don't know "c").
I've opted for AVRA to write my AVR-code. I've loaded the files via synaptic. I need to "install" or, "make" at this point..Don't understand "make". I got a lot of input but, I haven't done this before--
I'm backto the same question. But, it's about AVRA..

Manfred Hampl (m-hampl) said : #7

For diagnostic purposes please provide the output of the following commands (to be executed in a terminal window):

uname -a
lsb_release -crid
apt-cache policy avra

Manfred Hampl (m-hampl) said : #8

What do you mean by "I've loaded the files via synaptic"?
Which files did you "load"?
Synaptic does not "load" files, but it downloads and install packages.

Per other instructions, I have AVRA loaded and it appears to be working.
Some of the items required to get there were downloaded. (git, make). I'm thinking Synaptic is a -bloated- s/w that doesn't do anything..) ..So much "help" that didn't work.. (I probably have a pile of unwanted stuff on my hard drive now.. -"scar tissue"..)
I've searched but, cannot find a manual for AVRA.
As I understand it, it's critical to have everything in place to program a chip. The mosaic of instruction to get there has voids. And searching the web yields more frustration; Is there a site that focuses on Programming AVRs?
I chose Ubuntu for it's real-time qualities.. It should be a good platform for audio. I have complaints!

I didn't have some services loaded. Didn't have a good script to work from. New to Ubuntu, the straws I've grasped may be enough to keep my head "above water" but, I may need more help.

uname -a
Linux matthew-Default-string 5.3.0-28-generic #30~18.04.1-Ubuntu SMP Fri Jan 17 06:14:09 UTC 2020 x86 64 x86 64 GNU/Linux

lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 18.04.3 LTS
Release: 18.04
Codename: Bionic

apt-cache policy avra
Command apt-cache policy avra
avra:
  Installed: 1.3.0-3
  Candidate: 1.3.0-3
  Version table:
*** 1.3.0-3 500
               500 http://us.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
               100 /var/lib/dpkg/status

Thanks actionparsnip, that solved my question.

I looked at "overview" of synaptic. Don't understand it. ..Don't see purpose of it. My loading of AVRA appears to have worked without it. Don't understand (or like) Windows either.. -I'm trying not to enter BIOS settings because of possible screw-up with the UEFI which I believe is the core of audio and re-start/power-down problems with many installations of ubuntu.
Thank you all for the support!

Manfred Hampl (m-hampl) said : #13

For synaptic:

I suggest that you read https://help.ubuntu.com/community/SynapticHowto

Ubuntu delivers software in packages and provides a package management system to install and uninstall such packages.
On Ubuntu server systems without graphics-oriented desktop you have to use command line tools to (download and) install software packages (e.g. the commands apt, apt-get and dpkg). These command line tools also work the same on desktop systems.
Synaptic offers a graphical front-end to these commands for desktop system.
There is even an additional tool named Ubuntu-Software, allowing you to search for software and to (download and) install it.

manfred: Followed your link. --Educated (to a degree).. -THANKS!
I think my problem is resolved. I've been using that information to try to correct my audio situation. -Instead of "dead-air" I've got a noisy output. -Making progress!
Please consider the question I originally posed as answered.
As a newbie, I have a lot of ground to cover just familiarizing.. (I'll probably pose another question when I've run out of ideas..)
Thanks again!

Manfred Hampl (m-hampl) said : #15

If you have problems with sound, you should follow https://help.ubuntu.com/community/SoundTroubleshootingProcedure preferably posting the results in a new question document.