Synaptic Issues in 17.10 that are supposed to be fixed

Asked by Dan G on 2018-01-26

I'm running Ubuntu 17.10 and I installed Synaptic (the official ubuntu documentation makes it seem that synaptic is now compatible: see ). However when I try to execute synaptic, nothing happens: I'm prompted for my password but afterwards, the process stalls and synaptic does not appear as running in the system processor.

However, after executing xhost si:localuser:root I can execute Synaptic by simply clicking the icon. However the issue persists after a restart or even after the command xhost -si:localuser:root. Is there any fix for this that doesn't involve doing what I'm currently doing?

Question information

English Edit question
Ubuntu synaptic Edit question
No assignee Edit question
Last query:
Last reply:
Manfred Hampl (m-hampl) said : #1

This is a known problem, Bug #1551951

Dan G (dan1111) said : #3

@m-hampl: This bud is supposed to have been solved, hence the title and

I'll edit my question to include this link.

Does apt-get work in terminal? Does muon-installer work OK?

Manfred Hampl (m-hampl) said : #5

How did you conclude that this problem is already solved?

Dan G (dan1111) said : #6

@m-hampl: I concluded that based on the fact that the online Ubuntu documentation (for 17.10) states that you can install and use Synaptic for package management ( I fail to understand why the official documentation would include this if there was well known issues with synaptic being used on wayland (as wayland is now used by default in the default session).

Dan G (dan1111) said : #7

@actionparsnip: I'm not sure what moun-installer is, but apt-get works fine. I've used it to install all the packages that I normally use. But it's nice to have synaptic as a functional part as searching the repositories with the command line is harder.

Manfred Hampl (m-hampl) said : #8

Synaptic is available in Ubuntu 17.10 and it works if you use the workarounds (e.g. xhost +si:localuser:root) as described in the bug report.

Can you help with this problem?

Provide an answer of your own, or ask Dan G for more information if necessary.

To post a message you must log in.