software index broken

Asked by alice on 2009-02-01

icon displayed at top of screen says unable to add or remove software.tried package manager synaptic it didn't work.don't know how to run sudo apt-get install f in terminal

ProblemType: Bug
Architecture: i386
Date: Sun Feb 1 18:36:04 2009
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/yelp
NonfreeKernelModules: nvidia
Package: yelp 2.20.0-0ubuntu3
PackageArchitecture: i386
ProcCmdline: yelp
ProcCwd: /home/alice
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: yelp
Uname: Linux computer-desktop 2.6.22-14-generic #1 SMP Tue Feb 12 07:42:25 UTC 2008 i686 GNU/Linux

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu synaptic Edit question
Assignee:
No assignee Edit question
Last query:
2009-02-07
Last reply:
2009-02-07

This question was originally filed as bug #324136.

alice (allyoop61) said : #1
Lars Ljung (larslj) said : #2

Hi,

To run the command from the terminal you should do this: start a terminal window from applications/accessories/terminal (I think that's the name in English). Enter "sudo apt-get install -f" without the quotes and then press the enter key. You will be prompted for your password (when you enter your password nothing will be shown on the screen, that's ok, just press enter after the password). This should repair the software index.

alice (allyoop61) said : #3

hi,I followed your instructions and it said command not found.I tried twice.Do you have any other suggestions?Thanks,Alice

Lars Ljung (larslj) said : #4

It's a common mistake to enter the quotes, you shouldn't do that. This is how it should look like:

user@desktop:~$ sudo apt-get install -f
[sudo] password for user:

More text will follow depending on the problems you have.

Open a Terminal from the menu Applications → Accessories → Terminal and type:
(if the system ask you a password give your user password, you will not see nothing when you type it, then press enter)

sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get --fix-missing install
sudo apt-get clean

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get clean
sudo apt-get autoremove

Hope this helps

alice (allyoop61) said : #6

thanks for all of your help but nothing seems to be working.everytime i type in what you both have told me to do it says command not found,and I need to run dpkg--configure-a manually.I don't know how to do that.exactly what does the software index do and what does it affect if it is broken?thanks again,Alice

alice please take care of spaces into the above commands:

sudo dpkg --configure -a

must be typed:

sudo <space> dpkg <space> --configure <space> -a

hope this helps

Can you help with this problem?

Provide an answer of your own, or ask alice for more information if necessary.

To post a message you must log in.