Synaptic can't find libavahi

Asked by JohnL on 2007-01-13

Synaptic can't install ANJUTA because it uses various libavahi files and synaptic can't find them.

It MAY be simply that avahi has a new site (since 5/1/2007) and synaptic is looking in the wrong place.

Of course, it could be something else entirely - I just want to know how to get the libavahi libraries required to install anjuta.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu synaptic Edit question
Assignee:
No assignee Edit question
Last query:
2007-01-21
Last reply:
2007-02-10
JohnL (cbarter) said : #2

Marcello Semboli wrote:
> Your support request #3161 on synaptic in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/synaptic/+ticket/3161
>
> Status: Open => Answered
>
> Marcello Semboli proposed the following answer:
> Enable others repository.
> Refer to https://help.ubuntu.com/6.10/ubuntu/desktopguide/C/extra-repositories.html
>
> _______________________________________________________________________
> If this answers your request, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+source/synaptic/+ticket/3161/+confirm?answer_id=0
>
> If you still need support, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/synaptic/+ticket/3161
>
>
I already have all repositories enabled. Its just that the avahi debs
aren't there - see error message below
quote...
W: Failed to fetch
http://security.ubuntu.com/ubuntu/pool/main/a/avahi/libavahi-common3_0.6.13-2ubuntu2.3_i386.deb
  404 Not Found

W: Failed to fetch
http://security.ubuntu.com/ubuntu/pool/main/a/avahi/libavahi-client3_0.6.13-2ubuntu2.3_i386.deb
  404 Not Found
...unquote

404 is "site not found", so it would appear that synaptic repositories
need to be updated for avahi's change of address.

That is, its not that I need help, someone needs to tell whoever
maintains synaptic.

John Lovely

JohnL (cbarter) said : #3

The problem appears to be with Synaptic. I have checked and the repository contains libavi-client3_0.6.13-2ubuntu2.4_i386.deb instead of the dependency version ...2.3_i396 required by anjuta

Kees Cook (kees) said : #4

In Synaptic, if you click "Reload" first, it should download the current list of available software. After that, try your install again, and it should download the correct versions.

Can you help with this problem?

Provide an answer of your own, or ask JohnL for more information if necessary.

To post a message you must log in.