Synaptic starts without admin privileges, only dl script feature offered

Asked by rtimai on 2012-11-06

Ubuntu (Unity) 12.10 64bit
Video M880G [Mobility Radeon HD 4200] no ATI/AMD fglrx
Kernel 3.5.0.18-generic
HP Pavilion dv6-3012he

Synaptic now starts without admin privileges and only able to create download scripts. Starting Synaptic manually from Terminal using 'synaptic-pkexec' prompt for sudo password, then opens an error window:

  E: The value 'precise' is invalid for APT::Default-Release as such a release
  is not available in the sources E: _cache->open() failed, please report.

Closing this window shuts down Synaptic. Run without admin privileges, Synaptic can create download scripts, but how this is better than simply running 'apt-get' is not clear.

Jeet (gour-jitendrasingh) said : #1

run once

sudo apt-get update && sudo apt-get upgrade

Thanks
~Jeet

rtimai (rtimai) said : #2

Actually, I have run sudo apt-get update && sudo apt-get upgrade several times, with no change.

Hoping that Synaptic was fixed with a new patched version, I just ran the commands again, and 'remote-login' was updated, but no effect on Synaptic Package Manager launcher, and running 'synaptic-pkexec' from Terminal still gets the same results as described earlier.

rtimai (rtimai) said : #3

Jeet,

I apologize for not thanking you for your response. Thanks! It's good to know that someone is seeing this.

Here is more information. I inspected /etc/apt/sources.list, and there is no instance of 'precise' in it. I also installed gconf-editor and searched for 'precise' (include key names & key values) and result is Not Found. I don't know how to check Dconf, if it's relevant.

--rtimai

rtimai (rtimai) said : #4

Jeet, I believe I've found the fix.

gksudo gedit /root/.synaptic/synaptic.conf

searched for 'precise' -- found one instance, and replaced it with 'quantal' and now synaptic-pkexec runs normally.

Solution found in:
https://bugs.launchpad.net/ubuntu/+source/synaptic/+bug/978821

Thanks for your time.

rtimai

Jeet (gour-jitendrasingh) said : #5

good to know that :)

Actually, I found this only happens when you try to luanch it from the unity tool bar after you have installed it. If you undock the icon that was created during install and then launch it from your dash... It will ask you to for authentication. Once you authenticate, lock it back to the launcher and it will work for now on.

Robert T (homeschoolu) said : #7

...I just had the problem, after installing synaptic into ubuntu 14.10 utopic.

The value 'trusty' is invalid for APT::Default-Release as such a release
  is not available in the sources E: _cache->open() failed, please report.

gksudo gedit /root/.synaptic/synaptic.conf

...This brought me the synaptic.conf.
...Alt+f brought me a search box.
...Entering 'trusty' bgrought the entry in synaptic.conf to me.

...I highlit trusty, then replaced it with utopic.

...Reopening synaptic, I encountered the same problem.

...Then, I ran sudo apt-get update.

...Now, synaptic opens from the menu and displays just fine.

...Thanks for sharing!

jondee (jonathandilks) said : #8

I've also encountered this and gksudo gedit /root/.synaptic/synaptic.conf fixed it! Should this be investigated as a bug? It's never happened during the upgrade process to me before until Vivid!