Updated from 11.10 to 12.04 on two computers. Synaptic crashes.

Asked by Per Ingulf Lillevold on 2012-05-09

Synaptic crashes (both computers, one desktop and one Asus Netbook: 1005H) and ubuntu sends error report, apt-get works just fine. When trying to start synaptic from command-line, it says memory segment fault, core dumped. Rebooting will not do any difference. Update Manager works just fine, so do Ubuntu Software center.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu synaptic Edit question
Assignee:
No assignee Edit question
Solved by:
Per Ingulf Lillevold
Solved:
2012-05-10
Last query:
2012-05-10
Last reply:
2012-05-10
Daniel Cheung (daniel-2345) said : #1

did you update synaptics

Sam_ (and-sam) said : #2

Leave Synaptic GUI closed and work from terminal only:
sudo apt-get clean
sudo apt-get autoremove

sudo apt-get update
sudo apt-get upgrade
sudo apt-get -f install

In case:
sudo dpkg-reconfigure synaptic

If no errors occur test Synaptic again and click on reload.
Don't run more than one package management GUI at once.

Thank you for answering me!

But sorry, this series of apt-get commands has been tested two or three times, but when I then try to start synaptic (from dash home), it asks for authentication, and once the authentication is given, synaptic opens for a second or two, then closes.

sudo synaptic -h tells me it is: synaptic for Debian 0.75.9 is that right?

sudo synaptic --upgrade-mode opens the GUI window, but the window closes before I can see what happens.

Please try:

sudo apt-get --purge --reinstall install synaptic

Hi,

The above command-line is a powerful one, but it did not work. I have tried following ideas:

1) Run Ubuntu 12.04 from an bootable USB-stick. No synaptic there, and impossible to run the one I had on the harddisk.

2) Start Ubuntu with an earlier version of the kernel. Did not work either.

3) REMOVE MY SELECTED LANGUAGE: Norwegian Bokmaal, and run Ubuntu 12.04 in plain English (American). Wow!!!! That solved the problem, now synaptic will run in its graphical mode. But now I have learned so much about apt-get that I would prefer using it directly, instead of via the graphical interface. Thank you!

Sam_ (and-sam) said : #6

> But now I have learned so much about apt-get that I would prefer using it directly

Great to hear. CLI is a handy tool and will always be, no matter how times are changing.

Same output here.
~$ synaptic -h
synaptic for Debian 0.75.9

Synaptic isn't in main anymore since 11.10, the focus lays on software-center.
Anyway I'd say the conflict with locales is worth a bug report.

I can confirm my experience with conflict with locales, when I entered my main desktop computer this afternoon. First I tried to complete one part of language configuration that was not completed at install (upgrade) time. That was not enough. Then I directed English (US) to first position in language selection, without deleting Norwegian bokmaal (on the other computer I unistalled Norwegian bokmaal). After rebooting, there were no longer a conflict, synaptic started as it should.

I can understand the focus on software-center, as it is an easier tool for everyone, it concentrates on the software package, as synaptic is a bit overwhelming in showing specific elements of the packages.

I will continue working in English (US), it gives me a feeling of working on the same level as my son, at RealNetworks, far, far away in Seattle. Thank you for taking the time to answer me!