Synaptic package manager loads, then instantly vanishes.

Asked by David Kirby on 2012-04-04

I run Ubuntu 11.10. When I click on "synaptic package manager", it asks for my password, which I type in, then the synaptic window starts loading, then it immediately vanishes. ????? The password is correct, everything else seems to be in order, but now the SPM, which once worked fine, now disappears. ?????

                                                                                        !!!!!!!!!!!

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu synaptic Edit question
Assignee:
No assignee Edit question
Last query:
2012-04-05
Last reply:
2012-04-10

If you run:

sudo apt-get update; sudo apt-get upgrade; sudo apt-get --reinstall synaptic

Does it upgrade ok?

John Papineau (j-lp) said : #2

you may have a corrupted ubuntu package in synaptic package manager .

John Papineau (j-lp) said : #3

It is sometime possible to fix the package manager depending on the damage done to it .

David Kirby (kirbster56-w) said : #4

andrew-woodhead666, I re-installed synaptic package manager using the terminal, using the command you gave me, and it still does the same thing. Maybe I should go back to Ubuntu 10.10 or 10.04. Hmmm.

v.miheer (v-miheer) said : #5

Try
$ sudo apt-get remove synaptic --purge
it it has any configuration issues it'll correct
then
$ sudo apt-get update
$ sudo apt-get install synaptic

Can you help with this problem?

Provide an answer of your own, or ask David Kirby for more information if necessary.

To post a message you must log in.