Synaptic PackLanguage:age Manager crashes upon opening

Asked by david widmayer on 2012-02-26

This question already asked, but answer did not solve problem.

 Installed Ubuntu 11.10 32-bit on netbook on 20.Feb 2012. Synaptic worked fine until last night when I did an apt-get update. Afterwards synaptic crashed after entering root password. I can not start it from a terminal window.

Synaptic version is current.

Who has a solution?

Question information

English Edit question
Ubuntu synaptic Edit question
No assignee Edit question
Last query:
Last reply:
Sam_ (and-sam) said : #1

> synaptic crashed

Was there an apport dialog, did you upload a report?
Did you search bug reports? Click on top of this page on 'Bugs'. Synaptic has some issues on Oneiric.

david widmayer (mayerwid) said : #2

Don't know what apport dialog is. No report generated or uploaded. How

Thank you for "Bugs" tip. Didn't find any relevant item.

Before the update synaptic worked fine.

Too bad.

Any further assistance or should I just wait for an update sometime in the future?

Sam_ (and-sam) said : #3

Verify if apport is enabled.

Then try to reproduce the crash with Synaptic and apport will generate a crash report.

In the meantime you can update via terminal with:
sudo apt-get update
sudo apt-get upgrade

david widmayer (mayerwid) said : #4

Hello Sam,

I already did ap-get update, apt-get upgrade a few times. didn't help.

I got a bug report as a file. no interactive window opened. can't open file because I don't have enough privileges (I am root).

I use gnome but also retried the unity and gnome classic desktops. same failure.

On my desktop computer, using unity, synaptic package manager starts and works fine.

This is very perplexing.

Sam_ (and-sam) said : #5

> I already did ap-get update, apt-get upgrade a few times. didn't help.

What do you mean it didn't help? Of course it doesn't help to repair Synaptic it's just another method to update the system when there is no GUI available.
Does the update run ok with apt-get or is there a general problem in getting updates?
In case post the terminal outputs.

> I don't have enough privileges (I am root).

On a standard Ubuntu installation you're not root, the root account is disabled and not supported.
There is a simple way to gain administration permissions temporarily with 'sudo'.
The crash file is in /var/crash.
To upload the file an example would be:
sudo ubuntu-bug /var/crash/<_the_crash_file>

david widmayer (mayerwid) said : #6

@Sam - I uploaded the report output as you indicated. Got a response that the

file libxml2 could be out of date. I then did an apt-get upgrade libxml2 and rebooted but still had the same problem.

At about the same time I also upgraded my desktop pc to ubuntu 11.10. (64 bit) synaptic package manager (still) runs on it without problems.

The problem came to be late saturday night when I was installing some stuff. I noticed it only on sunday when i cranked up the netbook and wanted to load another applicaton.

I tried to remember what I did the night before and reverse it.

The brutal solution would be to re-install ubuntu 11.10, but I still hope there is a less radical fix.

Thanks again for your suggestions.

Sam_ (and-sam) said : #7

> problem came to be late saturday night

Have a look at /var/log/apt/term.log or - /history.log
In case remove the assumed culprit package.

In addition to update & upgrade also try:
sudo apt-get dist-upgrade
sudo apt-get -f install
sudo dpkg-reconfigure synaptic

A reinstall isn't brutal when there is a separate /home partition, it's flawless then because all user config and data stay untouched.

Can you help with this problem?

Provide an answer of your own, or ask david widmayer for more information if necessary.

To post a message you must log in.