cannot access or open repositories in synaptic package manager or open update manager

Asked by ken Johnson on 2012-01-30

Why do have to re-install linux everytime it upgrades to something higher than 10.04 ?

After an upgrade from 10.04 I find myself locked out of my repositories in Synaptic and Update Manager will not come up at all when it is selected.

My only recourse is to install it all over again ... and this last p-----s me to no end. Is there something that can be done to open up those closed repositories?

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: synaptic 0.63.1ubuntu7
ProcVersionSignature: Ubuntu 2.6.32-38.83-generic 2.6.32.52+drm33.21
Uname: Linux 2.6.32-38-generic i686
Architecture: i386
Date: Mon Jan 30 12:29:49 2012
ExecutablePath: /usr/sbin/synaptic
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: synaptic

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu synaptic Edit question
Assignee:
No assignee Edit question
Last query:
2012-01-31
Last reply:
2012-02-01

Individual breakage, no intention to log deficiency.

Can you give any error messages? I would love to try and help.

ken Johnson (arseenowe) said : #3

There are no error messages to given by Synaptic Package Manager or Update Manager.

And, yes, I would love you to try to help me in this.

Can you try closing synaptic/update manager and run 'sudo apt-get update && sudo apt-get upgrade' in the terminal? If it gives you errors, please copy/paste them here.

ken Johnson (arseenowe) said : #5

ken@ken-laptop:~$ sudo apt-get update && sudo apt-get upgrade
[sudo] password for ken:
Hit http://archive.canonical.com lucid Release.gpg
Ign http://archive.canonical.com/ubuntu/ lucid/partner Translation-en
Hit http://us.archive.ubuntu.com lucid Release.gpg
Ign http://us.archive.ubuntu.com/ubuntu/ lucid/main Translation-en
Ign http://us.archive.ubuntu.com/ubuntu/ lucid/main Translation-en_US
Hit http://archive.ubuntu.com maverick Release.gpg
Ign http://archive.ubuntu.com/ubuntu/ maverick/main Translation-en
Ign http://archive.ubuntu.com/ubuntu/ maverick/main Translation-en_US
Get:1 http://security.ubuntu.com lucid-security Release.gpg [198B]
Ign http://security.ubuntu.com/ubuntu/ lucid-security/main Translation-en
Ign http://security.ubuntu.com/ubuntu/ lucid-security/main Translation-en_US
Ign http://archive.canonical.com/ubuntu/ lucid/partner Translation-en_US
Hit http://archive.canonical.com lucid Release
Ign http://us.archive.ubuntu.com/ubuntu/ lucid/multiverse Translation-en
Ign http://us.archive.ubuntu.com/ubuntu/ lucid/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ lucid/restricted Translation-en
Ign http://us.archive.ubuntu.com/ubuntu/ lucid/restricted Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ lucid/universe Translation-en
Ign http://us.archive.ubuntu.com/ubuntu/ lucid/universe Translation-en_US
Hit http://us.archive.ubuntu.com lucid Release
Ign http://archive.ubuntu.com/ubuntu/ maverick/restricted Translation-en
Ign http://archive.ubuntu.com/ubuntu/ maverick/restricted Translation-en_US
Ign http://archive.ubuntu.com/ubuntu/ maverick/universe Translation-en
Ign http://archive.ubuntu.com/ubuntu/ maverick/universe Translation-en_US
Hit http://archive.ubuntu.com natty Release.gpg
Ign http://archive.ubuntu.com/ubuntu/ natty/main Translation-en
Ign http://archive.ubuntu.com/ubuntu/ natty/main Translation-en_US
Ign http://archive.ubuntu.com/ubuntu/ natty/restricted Translation-en
Ign http://archive.ubuntu.com/ubuntu/ natty/restricted Translation-en_US
Ign http://archive.ubuntu.com/ubuntu/ natty/universe Translation-en
Ign http://security.ubuntu.com/ubuntu/ lucid-security/multiverse Translation-en
Ign http://security.ubuntu.com/ubuntu/ lucid-security/multiverse Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ lucid-security/restricted Translation-en
Ign http://security.ubuntu.com/ubuntu/ lucid-security/restricted Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ lucid-security/universe Translation-en
Ign http://security.ubuntu.com/ubuntu/ lucid-security/universe Translation-en_US
Get:2 http://security.ubuntu.com lucid-security Release [57.3kB]
Ign http://archive.ubuntu.com/ubuntu/ natty/universe Translation-en_US
Hit http://archive.ubuntu.com maverick Release
Hit http://archive.ubuntu.com natty Release
Hit http://archive.canonical.com lucid/partner Sources
Hit http://us.archive.ubuntu.com lucid/main Sources
Hit http://archive.canonical.com lucid/partner i386 Packages
Hit http://archive.ubuntu.com maverick/main i386 Packages
Hit http://us.archive.ubuntu.com lucid/restricted Sources
Hit http://us.archive.ubuntu.com lucid/universe Sources
Hit http://us.archive.ubuntu.com lucid/multiverse Sources
Hit http://us.archive.ubuntu.com lucid/main i386 Packages
Hit http://us.archive.ubuntu.com lucid/restricted i386 Packages
Hit http://us.archive.ubuntu.com lucid/universe i386 Packages
Hit http://us.archive.ubuntu.com lucid/multiverse i386 Packages
Hit http://archive.ubuntu.com maverick/restricted i386 Packages
Hit http://archive.ubuntu.com maverick/universe i386 Packages
Hit http://archive.ubuntu.com natty/main i386 Packages
Hit http://archive.ubuntu.com natty/restricted i386 Packages
Hit http://archive.ubuntu.com natty/universe i386 Packages
Get:3 http://security.ubuntu.com lucid-security/main Sources [74.1kB]
Get:4 http://security.ubuntu.com lucid-security/restricted Sources [14B]
Get:5 http://security.ubuntu.com lucid-security/universe Sources [29.7kB]
Get:6 http://security.ubuntu.com lucid-security/multiverse Sources [1,754B]
Get:7 http://security.ubuntu.com lucid-security/main i386 Packages [260kB]
Get:8 http://security.ubuntu.com lucid-security/restricted i386 Packages [14B]
Get:9 http://security.ubuntu.com lucid-security/universe i386 Packages [109kB]
Get:10 http://security.ubuntu.com lucid-security/multiverse i386 Packages [4,557B]
Fetched 537kB in 2s (245kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 gtk2-engines-pixbuf : Depends: libgtk2.0-0 (= 2.24.4-0ubuntu2) but 2.22.0-0ubuntu1 is installed
 kdepimlibs5 : Depends: libakonadi-kde4 (= 4:4.6.2-0ubuntu1) but it is not installed
               Depends: libakonadi-kmime4 (= 4:4.6.2-0ubuntu1) but it is not installed
               Depends: libgpgme++2 (= 4:4.6.2-0ubuntu1) but it is not installed
               Depends: libkabc4 (= 4:4.6.2-0ubuntu1) but it is not installed
               Depends: libkblog4 (= 4:4.6.2-0ubuntu1) but it is not installed
               Depends: libkcal4 (= 4:4.6.2-0ubuntu1) but it is not installed
               Depends: libkholidays4 (= 4:4.6.2-0ubuntu1) but it is not installed
               Depends: libkimap4 (= 4:4.6.2-0ubuntu1) but it is not installed
               Depends: libkldap4 (= 4:4.6.2-0ubuntu1) but it is not installed
               Depends: libkmime4 (= 4:4.6.2-0ubuntu1) but it is not installed
               Depends: libkpimidentities4 (= 4:4.6.2-0ubuntu1) but it is not installed
               Depends: libkpimtextedit4 (= 4:4.6.2-0ubuntu1) but it is not installed
               Depends: libkpimutils4 (= 4:4.6.2-0ubuntu1) but it is not installed
               Depends: libkresources4 (= 4:4.6.2-0ubuntu1) but it is not installed
               Depends: libktnef4 (= 4:4.6.2-0ubuntu1) but it is not installed
               Depends: libkxmlrpcclient4 (= 4:4.6.2-0ubuntu1) but it is not installed
               Depends: libmailtransport4 (= 4:4.6.2-0ubuntu1) but it is not installed
               Depends: libmicroblog4 (= 4:4.6.2-0ubuntu1) but it is not installed
               Depends: libqgpgme1 (= 4:4.6.2-0ubuntu1) but it is not installed
               Depends: libsyndication4 (= 4:4.6.2-0ubuntu1) but it is not installed
               Depends: kdepimlibs-kio-plugins (= 4:4.6.2-0ubuntu1) but it is not installed
 libgail18 : Depends: libgtk2.0-0 (= 2.24.4-0ubuntu2) but 2.22.0-0ubuntu1 is installed
 libqt4-dbus : Depends: libqtcore4 (= 4:4.7.2-0ubuntu6) but 4:4.7.0-0ubuntu4 is installed
 libqt4-designer : Depends: libqtcore4 (= 4:4.7.2-0ubuntu6) but 4:4.7.0-0ubuntu4 is installed
 libqt4-help : Depends: libqtcore4 (= 4:4.7.2-0ubuntu6) but 4:4.7.0-0ubuntu4 is installed
 libqt4-network : Depends: libqtcore4 (= 4:4.7.2-0ubuntu6) but 4:4.7.0-0ubuntu4 is installed
 libqt4-opengl : Depends: libqtcore4 (= 4:4.7.2-0ubuntu6) but 4:4.7.0-0ubuntu4 is installed
 libqt4-qt3support : Depends: libqtcore4 (= 4:4.7.2-0ubuntu6) but 4:4.7.0-0ubuntu4 is installed
 libqt4-script : Depends: libqtcore4 (= 4:4.7.2-0ubuntu6) but 4:4.7.0-0ubuntu4 is installed
 libqt4-scripttools : Depends: libqtcore4 (= 4:4.7.2-0ubuntu6) but 4:4.7.0-0ubuntu4 is installed
 libqt4-sql : Depends: libqtcore4 (= 4:4.7.2-0ubuntu6) but 4:4.7.0-0ubuntu4 is installed
 libqt4-sql-mysql : Depends: libqtcore4 (= 4:4.7.2-0ubuntu6) but 4:4.7.0-0ubuntu4 is installed
 libqt4-sql-sqlite : Depends: libqtcore4 (= 4:4.7.2-0ubuntu6) but 4:4.7.0-0ubuntu4 is installed
 libqt4-svg : Depends: libqtcore4 (= 4:4.7.2-0ubuntu6) but 4:4.7.0-0ubuntu4 is installed
 libqt4-test : Depends: libqtcore4 (= 4:4.7.2-0ubuntu6) but 4:4.7.0-0ubuntu4 is installed
 libqt4-xml : Depends: libqtcore4 (= 4:4.7.2-0ubuntu6) but 4:4.7.0-0ubuntu4 is installed
 libqt4-xmlpatterns : Depends: libqtcore4 (= 4:4.7.2-0ubuntu6) but 4:4.7.0-0ubuntu4 is installed
 libqtgui4 : Depends: libqtcore4 (= 4:4.7.2-0ubuntu6) but 4:4.7.0-0ubuntu4 is installed
             Recommends: appmenu-qt but it is not installed
 plymouth : Depends: libdrm-nouveau1a (>= 2.4.23) but it is not installed
            Depends: libplymouth2 (= 0.8.2-2ubuntu22) but 0.8.2-2ubuntu2.2 is installed
            Depends: udev (>= 166-0ubuntu4) but 162-2 is installed
 plymouth-label : Depends: libplymouth2 (= 0.8.2-2ubuntu22) but 0.8.2-2ubuntu2.2 is installed
 plymouth-x11 : Depends: libplymouth2 (= 0.8.2-2ubuntu22) but 0.8.2-2ubuntu2.2 is installed
E: Unmet dependencies. Try using -f.
ken@ken-laptop:~$

Ah, you see, your computer is checking for updates for both version 10.04 and 10.10. Did you have a power failure during the upgrade process?

This is easily fixable, but will need some terminal magic. Open up a terminal and run:

'sudo nano /etc/apt/sources.list'

Now you need to hunt down every line that says "Lucid" and replace "Lucid" with "Maverick".

For instance, here's my very-similar sources.list that lists 11.10, or "Oneiric":

---------------------------------

# deb cdrom:[Ubuntu 10.10 _natty Meerkat_ - Release amd64 (20101007)]/ natty main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://us.archive.ubuntu.com/ubuntu/ oneiric main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ oneiric main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://us.archive.ubuntu.com/ubuntu/ oneiric-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ oneiric-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ oneiric universe
deb-src http://us.archive.ubuntu.com/ubuntu/ oneiric universe
deb http://us.archive.ubuntu.com/ubuntu/ oneiric-updates universe
deb-src http://us.archive.ubuntu.com/ubuntu/ oneiric-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://us.archive.ubuntu.com/ubuntu/ oneiric multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ oneiric multiverse
deb http://us.archive.ubuntu.com/ubuntu/ oneiric-updates multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ oneiric-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://us.archive.ubuntu.com/ubuntu/ natty-backports main restricted universe multiverse
# deb-src http://us.archive.ubuntu.com/ubuntu/ natty-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu oneiric partner
# deb-src http://archive.canonical.com/ubuntu natty partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu oneiric main
deb-src http://extras.ubuntu.com/ubuntu oneiric main

deb http://security.ubuntu.com/ubuntu oneiric-security main restricted
deb-src http://security.ubuntu.com/ubuntu oneiric-security main restricted
deb http://security.ubuntu.com/ubuntu oneiric-security universe
deb-src http://security.ubuntu.com/ubuntu oneiric-security universe
deb http://security.ubuntu.com/ubuntu oneiric-security multiverse
deb-src http://security.ubuntu.com/ubuntu oneiric-security multiverse

-------------------------------------

After correctly switching these items, run 'sudo apt-get update && sudo apt-get upgrade' once more. It'll take some time to fix the situation, I imagine, but all should be dandy after that! Let me know what happens, and good luck.

Please note that in my above answer, the first line of my sources.list,

"# deb cdrom:[Ubuntu 10.10 _natty Meerkat_ - Release amd64 (20101007)]/ natty main restricted"

Means nothing. It says 10.10, natty and Meerkat just because this was installed on my computer long ago during that release cycle.

once again, sorry.

To exit from the editing program you'll be using, press 'control+x', then y, then enter.

Can you help with this problem?

Provide an answer of your own, or ask ken Johnson for more information if necessary.

To post a message you must log in.