residual configuration of packages in Synaptic and i cant purge them

Asked by elhoir on 2011-10-19

Hello,

When i use synaptic, i have seen that i have a lot of packages into the "residual configuration" set, but when i select them for purging, i cannot "apply", i have to make another action (upgrade, install, remove) to make it possible...

im using Ubuntu 11.04

is it a bug? is it a normal behavior?

thank you so much

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu synaptic Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2011-10-20
Last query:
2011-10-20
Last reply:
2011-10-20

Can you give the output of:

dpkg -l | grep '^rc'; echo; lsb_release -a

Thanks

elhoir (jfarroyo82) said : #2

elhoir@elhoir:~/Descargas$ dpkg -l | grep '^rc'; echo; lsb_release -a
rc byobu 3.33-0ubuntu1 a set of useful profiles and a profile-switcher for GNU screen
rc esound-clients 0.2.41-8 Enlightened Sound Daemon - clients
rc fancontrol 1:3.2.0-1ubuntu1 utilities to read temperature/voltage/fan sensors
rc libalut0 1.1.0-2 OpenAL Utility Toolkit
rc libavutil49 4:0.5.1-1ubuntu1 ffmpeg utility library
rc libcamel1.2-14 2.30.3-2ubuntu2.1 The Evolution MIME message handling library
rc libdbusmenu-glib1 0.3.16-0ubuntu1 library for passing menus over DBus
rc libdbusmenu-gtk1 0.3.16-0ubuntu1 library for passing menus over DBus - GTK+ version
rc libdirectfb-1.2-0 1.2.8-5ubuntu2 direct frame buffer graphics - shared libraries
rc libdns66 1:9.7.1.dfsg.P2-2ubuntu0.3 DNS Shared Library used by BIND
rc libdrm-nouveau1 2.4.22-2ubuntu1 Userspace interface to nouveau-specific kernel DRM services -- runtime
rc libebml2 1.0.0+dfsg-0ubuntu1 access library for the EBML format
rc libebook1.2-9 2.30.3-2ubuntu2.1 Client library for evolution address books
rc libecal1.2-7 2.30.3-2ubuntu2.1 Client library for evolution calendars
rc libedata-book1.2-2 2.30.3-2ubuntu2.1 Backend library for evolution address books
rc libedata-cal1.2-7 2.30.3-2ubuntu2.1 Backend library for evolution calendars
rc libedataserver1.2-13 2.30.3-2ubuntu2.1 Utility library for evolution data servers
rc libedataserverui1.2-8 2.30.3-2ubuntu2.1 GUI utility library for evolution data servers
rc libeggdbus-1-0 0.6-1 D-Bus bindings for GObject
rc libexiv2-6 0.19-3 EXIF/IPTC metadata manipulation library
rc libfolks-telepathy0 0.1.17-0ubuntu2 Telepathy backend for libfolks
rc libfolks0 0.1.17-0ubuntu2 library to aggregates people into metacontacts
rc libgadu3 1:1.10.1-1 Gadu-Gadu protocol library - runtime files
rc libgdata-google1.2-1 2.30.3-2ubuntu2.1 Client library for accessing Google POA through SOAP interface
rc libgdata1.2-1 2.30.3-2ubuntu2.1 Client library for accessing Google POA through SOAP interface
rc libgdata7 0.6.4-2 Library for accessing GData webservices - shared libraries
rc libgirepository1.0-1 0.9.3-0ubuntu4 Library for handling GObject introspection data (runtime library)
rc libgladeui-1-9 3.7.0.is.3.6.7-0ubuntu2 GTK+ User Interface Build core library
rc libgnomevfs2-extra 1:2.24.4-0ubuntu4 GNOME Virtual File System (extra modules)
rc libgs8 8.71.dfsg.2-0ubuntu7 The Ghostscript PostScript/PDF interpreter Library
rc libgwibber0 0.0.6-0ubuntu1 Gwibber - shared library
rc libicu42 4.2.1-3 International Components for Unicode
rc libimobiledevice1 1.0.1-1 Library for communicating with the iPhone and iPod Touch
rc libindicate4 0.4.4-0ubuntu2 library for raising indicators via DBus
rc libindicator1 0.3.14-0ubuntu1 panel indicator applet - shared library
rc libisc60 1:9.7.1.dfsg.P2-2ubuntu0.3 ISC Shared Library used by BIND
rc libisccfg60 1:9.7.1.dfsg.P2-2ubuntu0.3 Config File Handling Library used by BIND
rc libjack0 1:0.118+svn4104-1ubuntu2 JACK Audio Connection Kit (libraries)
rc libmatroska2 1.0.0+repack-0ubuntu1 extensible open standard audio/video container format
rc libmlt2 0.5.6+git20100727-1 multimedia framework (runtime)
rc libmodplug0c2 1:0.8.7-1build1 shared libraries for mod music based on ModPlug
rc libmpcdec3 1:1.2.2-2.1ubuntu1 Musepack (MPC) format library
rc libnice0 0.0.12-1 ICE library (shared library)
rc libpango1.0-common 1.28.2-0ubuntu1.1 Modules and configuration files for the Pango
rc libpolkit-qt-1-0 0.95.1-1ubuntu1 PolicyKit-qt-1 library
rc libpoppler-glib4 0.12.4-0ubuntu5.1 PDF rendering library (GLib-based shared library)
rc libpoppler-glib5 0.14.3-0ubuntu1.2 PDF rendering library (GLib-based shared library)
rc libpoppler5 0.12.4-0ubuntu5.1 PDF rendering library
rc libpoppler7 0.14.3-0ubuntu1.2 PDF rendering library
rc libpython2.6 2.6.6-6ubuntu7 Shared Python runtime library (version 2.6)
rc libreoffice-filter-binfilter 1:3.3.2-1ubuntu5 office productivity suite -- legacy filters (e.g. StarOffice 5.2)
rc libsexy2 0.1.11-2build2 collection of additional GTK+ widgets - library
rc libsoundtouch1c2 1.3.1-2 sound stretching library
rc libtelepathy-logger1 0.1.5-1ubuntu1 Telepathy logger service - utility library
rc libwebkit-1.0-2 1.2.5-0ubuntu0.10.10.1 Web content engine library for Gtk+
rc libwpd8c2a 0.8.14-1build1 Library for handling WordPerfect documents (shared library)
rc libwpg-0.1-1 0.1.3-1build1 WordPerfect graphics import/convert library (shared library)
rc libwps-0.1-1 0.1.2-1build1 Works text file format import filter library (shared library)
rc libx264-85 2:0.85.1448+git1a6d32-4 x264 video coding library
rc libxapian15 1.0.20-2 Search engine library
rc libxmlrpc-core-c3 1.06.27-1ubuntu7 A lightweight RPC library based on XML and HTTP (core libraries)
rc openoffice.org-common 1:3.3.0-7ubuntu2 office productivity suite -- arch-independent files
rc openoffice.org-core 1:3.2.1-7ubuntu1.1 office productivity suite -- arch-dependent files
rc sreadahead 1:0.100.0-8 Transitional package for ureadahead
rc virtualbox-3.2 3.2.12-68302~Ubuntu~maverick Oracle VM VirtualBox
rc xfonts-100dpi 1:1.0.3 100 dpi fonts for X
rc xfonts-75dpi 1:1.0.3 75 dpi fonts for X
rc xulrunner-1.9.2 1.9.2.17+build3+nobinonly-0ubuntu1 XUL + XPCOM application runner

LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty
elhoir@elhoir:~/Descargas$

Yikes that's loads.

Run:
dpkg -l | grep '^rc' | awk '{print $2}' | xargs dpkg --purge

and it will clean up that rubbish.

Source:
https://help.ubuntu.com/community/AptGet/Howto

elhoir (jfarroyo82) said : #4

Thanks actionparsnip, that solved my question.