synaptic package manager does't start anymore

Asked by Horst Seeger on 2011-10-18

After upgrade to ubuntu 11.10 first synaptic worked normal. Then it started to flash only without starting. When I tried to start through terminal I got this error message:

(gksudo:16652): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
terminate called after throwing an instance of 'std::out_of_range'
  what(): vector::_M_range_check

What is the problem and how to solve it?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu synaptic Edit question
Assignee:
No assignee Edit question
Solved by:
Horst Seeger
Solved:
2011-10-18
Last query:
2011-10-18
Last reply:
2011-10-18

sudo apt-get install gtk2-engines-pixbuf

Should cure the warning.

https://bugs.launchpad.net/ubuntu/+source/synaptic/+bug/807771
See post #7
Seems to fix it.

Horst Seeger (horstseeger) said : #2

on:
sudo apt-get install gtk2-engines-pixbuf
I got answer, that it is installed already

but switching off "visual alerts" in Universal Access (post n° 7) has cured it. Thanks!