synaptic does not run on Ubuntu 11.10

Asked by Eugenio Aguilar on 2011-10-18

after reload from disk Ubuntu 11.10 I try to run Synaptic package manager and it does not respond.

Then I reload Synaptic from the terminal I run it again and it don't work either, this is the Terminal output:

eu@eu-Vostro-330:~$ sudo apt-get install synaptic
[sudo] password for eu:
Reading package lists... Done
Building dependency tree
Reading state information... Done
synaptic is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
eu@eu-Vostro-330:~$ sudo synaptic

(process:2340): Gtk-WARNING **: Locale not supported by C library.
 Using the fallback 'C' locale.
terminate called after throwing an instance of 'std::out_of_range'
  what(): vector::_M_range_check

I don't understand the last 4 lines

How can I solve this problem?

Thank you for your help.

Eugenio

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu synaptic Edit question
Assignee:
No assignee Edit question
Last query:
2011-11-01
Last reply:
2011-11-04

Do NOT run GUI apps with sudo. Instead run:

gksudo synaptic

Sudo doesn't setup the environment correctly for GUI apps. The equivelant in KDE is kdesudo

Eugenio Aguilar (chimborito) said : #2

Synapic has been reinstalled with sudo, gksudo and kdesudo and appears in the dashboard, but it does not run; always the same message in the terminal:

eu@eu-Vostro-330:~$ sudo synaptic
[sudo] password for eu:

(process:3173): Gtk-WARNING **: Locale not supported by C library.
 Using the fallback 'C' locale.
terminate called after throwing an instance of 'std::out_of_range'
  what(): vector::_M_range_check

Any idea?

thank you Andrew again for your answers

Eugenio

again, run synaptic ONLY with gksudo.

If you run:
sudo dpkg-reconfigure locales

Does it fix the issue?

Eugenio Aguilar (chimborito) said : #4

Sorry Andrew I forgot tell you Idid that yesterday, I repeat your instruction a few moments ago, with the next outputs:

eu@eu-Vostro-330:~$ sudo dpkg-reconfigure locales
[sudo] password for eu:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
 LANGUAGE = "en_US:en",
 LC_ALL = (unset),
 LC_MESSAGES = "en_US.UTF-8",
 LC_COLLATE = "en_US.UTF-8",
 LC_CTYPE = "en_US.UTF-8",
 LANG = "es_MX.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales...
  en_AG.UTF-8... up-to-date
  en_AU.UTF-8... up-to-date
  en_BW.UTF-8... up-to-date
  en_CA.UTF-8... up-to-date
  en_DK.UTF-8... up-to-date
  en_GB.UTF-8... up-to-date
  en_HK.UTF-8... up-to-date
  en_IE.UTF-8... up-to-date
  en_IN.UTF-8... up-to-date
  en_NG.UTF-8... up-to-date
  en_NZ.UTF-8... up-to-date
  en_PH.UTF-8... up-to-date
  en_SG.UTF-8... up-to-date
  en_US.UTF-8... up-to-date
  en_ZA.UTF-8... up-to-date
  en_ZM.UTF-8... up-to-date
  en_ZW.UTF-8... up-to-date
Generation complete.
eu@eu-Vostro-330:~$ gksudo synaptic

(process:3464): Gtk-WARNING **: Locale not supported by C library.
 Using the fallback 'C' locale.
eu@eu-Vostro-330:~$

As you can see, the part:

Please check that your locale settings:
 LANGUAGE = "en_US:en",
 LC_ALL = (unset),
 LC_MESSAGES = "en_US.UTF-8",
 LC_COLLATE = "en_US.UTF-8",
 LC_CTYPE = "en_US.UTF-8",
 LANG = "es_MX.UTF-8"
    are supported and installed on your system.
seems to be the problem.

Am I ok?
if that is so
How can I install that settings?

Thank you once more time.

Eugenio

Try:

export LC_ALL=en_US.UTF-8

Then retry

Eugenio Aguilar (chimborito) said : #6

Hellow andrew, this are my outputs:

eu@eu-Vostro-330:~$ export LC_ALL=en_US.UTF-8
eu@eu-Vostro-330:~$ gksudo synaptic
  what(): vector::_M_range_check
 instance of 'std::out_of_range'

I ran also:

eu@eu-Vostro-330:~$ sudo dpkg-reconfigure locales
Generating locales...
  en_AG.UTF-8... up-to-date
  en_AU.UTF-8... up-to-date
  en_BW.UTF-8... up-to-date
  en_CA.UTF-8... up-to-date
  en_DK.UTF-8... up-to-date
  en_GB.UTF-8... up-to-date
  en_HK.UTF-8... up-to-date
  en_IE.UTF-8... up-to-date
  en_IN.UTF-8... up-to-date
  en_NG.UTF-8... up-to-date
  en_NZ.UTF-8... up-to-date
  en_PH.UTF-8... up-to-date
  en_SG.UTF-8... up-to-date
  en_US.UTF-8... up-to-date
  en_ZA.UTF-8... up-to-date
  en_ZM.UTF-8... up-to-date
  en_ZW.UTF-8... up-to-date
Generation complete.
eu@eu-Vostro-330:~$

I don't know if en_US.UTF-8... up-to-date is the missing var,

I am sorry for so many answers, but Ubuntu without Synaptic is Ubuntu without legs.

Thank you again
Eugenio

Tried software centre?

Eugenio Aguilar (chimborito) said : #8

After a lot of work I change the Ubuntu server to:

http://mirrors.mit.edu/ubuntu

A lot of problem were solved but:
Now I changed to http://mirrors.mit.edu/ubuntu
some things were solved as the repair of the packages and the udate of the system, but Synaptic package manager does not work yet.

This is the terminal output:

*******************************
eu@eu-Vostro-330:~$ sudo apt-get install synaptic
Reading package lists... Done
Building dependency tree
Reading state information... Done
synaptic is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
eu@eu-Vostro-330:~$ gksudo synaptic

(gksudo:3423): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
eu@eu-Vostro-330:~$

*****************************************
as you can see Synaptic was installed ok. but it don't ran.

Then
I found elsewere a tip.
sudo apt-get install gtk2-engines-pixbuf
here goes the output:

******************************************
eu@eu-Vostro-330:~$ sudo apt-get install gtk2-engines-pixbuf
[sudo] password for eu:
Sorry, try again.
[sudo] password for eu:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
gtk2-engines-pixbuf
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 127 kB of archives.
After this operation, 1,069 kB of additional disk space will be used.
Get:1 http://mirrors.mit.edu/ubuntu/ oneiric/universe gtk2-engines-pixbuf i386 2.24.6-0ubuntu5 [127 kB]
Fetched 127 kB in 1s (126 kB/s)
Selecting previously deselected package gtk2-engines-pixbuf.
(Reading database ... 226975 files and directories currently installed.)
Unpacking gtk2-engines-pixbuf (from .../gtk2-engines-pixbuf_2.24.6-0ubuntu5_i386.deb) ...
Setting up gtk2-engines-pixbuf (2.24.6-0ubuntu5) ...

************************************************

The error message:

(gksudo:3423): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

does not appear now, but...

Synaptic only stays an instant in the screen and disappears, only that now ther is not an error message.

This is annoying.

Please any other idea?

Thank you

Eugenio

Daniel Brainard (dbrainard07) said : #9

I'm having the same problem, it is really annoying. Please let me know if you get anywhere resolving it.

Thanks,
Daniel

Eugenio Aguilar (chimborito) said : #10

No one Daniel
I knew there is a bug nobody is working on it; look at:

https://bugs.launchpad.net/ubuntu/+source/synaptic/+bug/807771

After a week lost I return to Ubuntu 11:04 that works smooth.

I will wait until Ubuntu 12:04

Good luck

Eugenio

On Sun, Oct 30, 2011 at 10:20 PM, Daniel Brainard <
<email address hidden>> wrote:

> Your question #175015 on synaptic in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/synaptic/+question/175015
>
> Daniel Brainard posted a new comment:
> I'm having the same problem, it is really annoying. Please let me know
> if you get anywhere resolving it.
>
> Thanks,
> Daniel
>
> --
> You received this question notification because you asked the question.
>

Does software centre do the same?

Eugenio Aguilar (chimborito) said : #12

Hello Andrew,

Yes Software centre did the same.

Soon I will install Ubuntu 11.10 in other partition in order to know more about it and see if a new installation overcomes the problem

Thank you again

Eugenio

Mauro (jasmines) said : #13

Try:

gsettings set org.gnome.desktop.interface toolkit-accessibility false

It worked for me.

Mdavies5 (mdavies5) said : #14

Well done Mauro! I had the same problem and your answer worked fine. How do you find these solutions?

Alan Herron (a-herron) said : #15

I was having the same problem...the Synaptic window would flash on, then off. Mauro's suggestion cured the disappearance, but after supplying the password an error window pops up with this content
=============
An error occurred
The following details are provided:
------------------
E: The value 'lucid-backports' is invalid for APT::Default-Release as such a release is not available in the sources
E: _cache->open() failed, please report.
=============
Closing the error window kills both it and the Synaptic window.

Any suggestions?

Eugenio Aguilar (chimborito) said : #16

Allan
May be return to Ubuntu 11.04 as I did.
I guess that bug is in the field of the designers of 11.10 version.
look at:
https://bugs.launchpad.net/ubuntu/+source/synaptic/+bug/807771

Good luck

Eugenio

Alan Herron (a-herron) said : #17

Thanks for the response Eugenio

Time isn't critical on this for me, so I'm going to wait for awhile and hope the problem is fixed in a update of 11.10 for the moment.

I posted the error information in the hope it might help. The reference to lucid suggests a configuration reference to 10.04 lucid lynx within synaptic is no longer valid, but the release is still listed on the documentation site. It might be possible to eliminate the reference using apt-get, but I don't know how if that is the case.

Alan

Can you help with this problem?

Provide an answer of your own, or ask Eugenio Aguilar for more information if necessary.

To post a message you must log in.