how to using downloaded iso image directly instead of cutting a DVD

Asked by s bahadur on 2011-09-17

I have already installed ubuntu 11.04 using the CD iso image using a USB boot device.

Now I have downloaded the DVD iso image for Ubuntu 11.04.
I do not wish to make a DVD unnecessarily.

I wish to install more packages from this iso image using synaptic.
But synaptic is insisting on mounting a DVD or cdrom, and there appears no way to get it to pick from the iso file.
Even if I mount the iso image in a directory /media/cdrom it is not picking up the image.

What is the way to configure it to pick from iso image file, of a local directory without automatic cdrom mounting.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu synaptic Edit question
Assignee:
No assignee Edit question
Solved by:
s bahadur
Solved:
2011-09-17
Last query:
2011-09-17
Last reply:
2011-09-17

You need to mount the ISO with something like:

sudo mkdir /media/iso; sudo mount -o loop /path/to/filename.iso /media/iso

Simply change /path/to/filename.iso to the actual filename and it will mount. I had someone ask this in #ubuntu but I forget the way to add it in software centre. I know it had something to do with:

deb file:///

But I can't remember the rest. I found it in a guide online so you may be able to find it (Getting ready for work now). But mounting the ISO is the first step

s bahadur (bahadur-sameer) said : #2

I tried the following

> sudo apt-cdrom -m add
   - from the messages figured out that it was looking for files in /media/apt

mounted the iso at /media/apt

> sudo mount -o loop /path/to/filename.iso /media/apt

re-tried
> sudo apt-cdrom -m add
  - this time it successfully marked some update

ran "synaptic" (network remained disconnected)
- it listed a new additional entry in the Repositories
- all the DVD packages got listed
- could successfully install packages

Great share! Hopefully others will find this and get fixed using your instruction :)

Glad you got the gold

s bahadur (bahadur-sameer) said : #4

Further runs of synaptic required the archive to be mounted at the location
 - /media/cdrom instead of /media/apt

so I'm not sure how the apt-cdrom command helped.