no puedo instalar postgresql

Asked by jessy santana on 2011-08-16

no puedo instalar POSTGRESQL, hay un error que me presenta por lo cual ni puedo instalar ningun paquete, ni instalar las actualizaciones de lugar, ya que el mensaje que me muestra el synaptic es...

E: postgresql-8.4: el subproceso instalado el script pre-removal devolvió el código de salida de error 1
E: postgresql-common: El paquete está en un estado muy malo e inconsistente - debe reinstalarlo antes de intentar desinstalarlo.

por favor indiquenme que hacer al respecto ya que no puedo hacer ninguna instalacion ni eliminacion...

Question information

Language:
Spanish Edit question
Status:
Answered
For:
Ubuntu synaptic Edit question
Assignee:
No assignee Edit question
Last query:
2011-08-16
Last reply:
2011-08-16
Sergio Meneses (sergiomeneses) said : #1

Saludos!

La verdad el problema es la primera vez que lo veo... intenta:

1o Actualiza los repositorios desde la terminal: $sudo apt-get update

2o Intenta instalar el postgresql desde consola: $sudo apt-get install postgresql postgresql-client postgresql-contrib libpq-dev pgadmin3

Luego de instalarlo puede acceder a el desde el pgadmin que estará en el menu de aplicaciones.

Aquí te dejo una guía aparte por si necesitas saber mas de postgres en ubuntu:
http://lobotuerto.com/blog/2009/07/20/como-instalar-postgresql-en-ubuntu-9-04-jaunty-jackalope/

Cualquier inconveniente nos comentas.

PD: No olvides poner tus preguntas como solucionadas!

Can you help with this problem?

Provide an answer of your own, or ask jessy santana for more information if necessary.

To post a message you must log in.