Backport version 4.6 to Trusty?

Asked by Alan Pater on 2015-06-15

What are the chances of getting version 4.6, out since February 2015, into trusty, or at least version 4.5 from willy backported?

I tried a simple download and dpkg -i of version 4.5 from willy, but there are unresolved dependencies.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu sweethome3d Edit question
Assignee:
No assignee Edit question
Solved by:
Alan Pater
Solved:
2015-06-16
Last query:
2015-06-16
Last reply:
2015-06-16

I suggest you report a bug

Manfred Hampl (m-hampl) said : #2

What unmet dependencies are there for the version 4.5 from wily?
Maybe you can also install the required dependent package(s) from wily without too much hassle?

You will get unmet deps if you use Wily as Wily has later versions of packages which the applications are compiled against. Did you really think that you could just use the Wily deb?

Think about how the package system works with how it satisfies deps and pulls in what is needed.... The only way you can use the Wily deb is to satisfy all the deps using More Wily deps. You will also need to satisfy those deps and so on. Eventually you will have some Frankenstein style monster that the community simply cannot support.

If Wily has what you need then wipe off Trusty and do a clean install of Wily. It isn't LTS though.

Alan Pater (alan-pater) said : #4

Thanks guys. I checked further and the only dependency was a newer libsunflow-java. So I downloaded the Wily deb for that and installed it along with sweethome3d_4.5.